Computer Operator and Programming Assistant
Trade Theory, Semester - I

Dr.V.Nagaradjane

September 22, 2018
History of computers

1) Logarithm - John Napier
2) Slide Rule - Edmund Gunter
3) Mechanical calculator - Wilhelm Schickard, Blaise Pascal

Figure: Early calculating devices[1]
4) **Difference engine (the first general purpose computer)** was invented by Charles Babbage (Father of modern computer) in the year 1822. Difference engine got input through punched cards. Output was provided through printers, curve ploter, card punched machine and bell.

![Difference engine](image1.png)

Figure: Difference engine (the first computer)[1]
Figure: Punched card[?]
5) **Analog computer** was invented by Sir William Thomson in 1872 for prediction of tides. Analog computers used continuously changing quantities (like water flow, electricity, etc.) for calculation purpose. Analog computers were not as accurate as digital computers.

Figure: Analog computer[1]
History of computers

6) **Code breaking machines** Machines like Colossus were used during World war II for breaking German military communications. These machines were not strictly compliant with Turing’s definition of computing machines.

Figure: Colossus[1]
History of computers

7) **First Generation computer (ENIAC)** ENIAC stands for Electronic Numerical Integrator And Computer. ENIAC was built by J. P. Eckert and J. W. Mauchy at the University of Pennsylvania in 1945. It used over 200 kW of electric power, 18,000 vacuum tubes and 1,500 relays and weighed over 3 tons. These machines used punched cards, paper tapes and magnetic tapes for data input and output. First generation computer used machine language for programming.
Vacuum tube

Figure: Vacuum tube
History of computers

8) **Second Generation computer** These computers used transistors for processing, magnetic core for primary storage, magnetic tape and magnetic disc for secondary storage. Second generation computers came into existence in the year 1959. High level programming languages like FORTRAN and COBOL were used to operate these computers.

Figure: Second generation computer[2]
History of computers

9) **Third Generation computer** Third generation of computers appeared in 1965. These computers used Integrated Circuit (IC) for processing. High-level languages like FORTRAN-II to IV, COBOL, PASCAL PL/1, BASIC, ALGOL-68 etc. were used. These machines had keyboard for input.

![Third generation computer](image3.png)

**Figure: Third generation computer[3]**
10) **Fourth Generation computer** Fourth generation computer was invented in 1971. These computers used Very Large Scale Integration (VLSI) technology. High-level languages like C, C++ and productivity applications like Wordstar, Lotus, DBASE, FOXPRO etc. were used. Internet was invented during the advent of fourth generation computers. Computer of the fourth generation were called Personal Computer (PC). Floppy disks and hard disks were used for secondary storage.
11) **Fifth Generation computer** Fifth generation computers are still evolving. Although it is said that the era of fifth generation computers began around 1980, their evolution is still happening. They focus on computing devices having artificial intelligence (self aware computers). Fifth generation computers were introduced in 1980. These computers use Ultra Large Scale Integration (ULSI) technology. High-level languages like C, C++, Java, C#.NET, etc. are used. Hard disk, compact disk, Digital Versatile Disk, Pen Drive, Memory card, etc. are used for secondary storage. Desktop computers, Laptops, NoteBooks (thin laptops), UltraBook (very thin laptops like MacBook Air), ChromeBook, etc. belong to the fifth generation of computers.
Types of computer

1) **Personal computer or Micro-computer** Small computer capable of supporting one user at a time (multiple users may login at different times) is called personal computer. The processor, memory capacity and storage capacity of a personal computer are very small compared to other types. Laptop, mobile phone, Raspberry PI, etc. are some examples of personal computer/micro-computer.
Types of computer

2) **Workstation computer** Workstation computer has higher computing power, higher graphics quality and higher storage capacity with better support for networking when compared to personal computer. Workstation computers are used for CAD/CAM application, desktop publication, high power gaming, etc.. Workstations are the professional version of a personal computer.

Figure: Workstation[7]
Types of computer

3) **Mini-computer** Mini-computer is more powerful than a personal computer, permits hundreds of persons to login at the same time (called multi-tasking), has enormous processing power. This computer supports the connection of several monitors, keyboards and mice to permit several persons to login and use multi-tasking ability of the computer. Mini-computer gets the name because it is smaller than a mainframe computer. It is much more powerful than a personal computer.
4) **Mainframe computer** Mainframe computer contains large number of processors, huge amount of RAM (in Tera bytes), large storage capacity and permits thousands of users to login at the same time. Mainframe computer can execute several thousands of programs concurrently. The main advantage of mainframe computer is the centralization of processing capacity and storage. Mainframe computers are costly.

Figure: Mainframe computer[6]
Types of computer

5) **Cloud computers** A collection of computers and other devices connected through the Internet for sharing of processing power and data storage capacity is called a cloud of computers. Since the number of machines is large, redundancy of machines ensures cent percent availability of data and processing power to the customers. Cloud based storage services charge their customers based on storage quota allotted on the cloud.
Types of computer

6) **Supercomputer** Supercomputers have several processors running at the same time and huge memory. Supercomputers focus on fast computation and number crunching operations (unlike the mainframes concentrating on support for large number of users). Supercomputers are used for scientific research, weather forecasting, circuit design, simulation of physical systems and large scale animations.
Advantages of computers

1) Computers are very fast in problem solving.
2) Digital computers are easy to program.
3) Computer Aided Design and Manufacturing help in the reduction of money, manpower and time required for completing a job.
4) Real time computers are useful in controlling mission critical operations.
Application of computers

1) Centralized computer systems help core banking transactions.
2) Online ticket reservation and e-commerce are made possible through computers connected to the Internet.
3) Supercomputers help in weather prediction.
4) Computers help in the creation of high quality multi-media content at faster rate and lower cost.
5) Computers are helpful in monitoring of production processes.
6) Online trading platforms supported by high speed computers provide real time access to share market investment.
7) Computers help in the creation of the Internet, Local Area Network (LAN), Wide Area Network (WAN), Metropolitan Area Network (MAN) for sharing of information.
Concept of hardware and software

Hardware and software are the body and mind of the computer. The physical hardware runs according to the directions of the invisible software. The main differences between hardware and software are presented in Table 1.

### Table: Hardware & software

<table>
<thead>
<tr>
<th>Sl. No.</th>
<th>Hardware</th>
<th>Software</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Physically accessible</td>
<td>Physically inaccessible</td>
</tr>
<tr>
<td>2</td>
<td>Can be touched, when power is off</td>
<td>Cannot be touched, whether power on or power off</td>
</tr>
<tr>
<td>3</td>
<td>Consumes lot of power</td>
<td>Causes other components to consume power to make them work. It does not consume any power.</td>
</tr>
<tr>
<td>4</td>
<td>Occupies space</td>
<td>Does not occupy visible space</td>
</tr>
<tr>
<td>5</td>
<td>Directly verifiable</td>
<td>Its existence is inferred through the working of hardware</td>
</tr>
</tbody>
</table>
Computer hardware

The parts of computer which can be seen and touched are called hardware. Generally, computer hardware consists of the following 3 units:

1. **Input unit**: Input unit helps to send commands and data to the Central Processing Unit (CPU) and fuels the processor of the computer. Keyboard, mouse, scanner, light pen, etc. are some of the common input units.

2. **Output unit**: The peripherals like Visual Display Unit (VDU)/Monitor, Printer, Plotter, etc. are some of the most common output units.

3. **Central Processing Unit (CPU)**: The Central Processing Unit (CPU) processes input data and produces results, which are output data.
Input unit

1) **Keyboard**: Keyboard is otherwise called console input unit. Common layout of keyboard supports English(US), English(UK) and local languages like Hindi, Tamil, etc.
2) **Mouse** - Mouse has LASER based or roller based tracking mechanism to measure change of position. The movement of the mouse causes movement of pointer on the VDU. Mouse has 3 buttons: (a) the left button, (b) the right button and (c) the centre button which doubles as mouse roller for scrolling.

Figure: Mouse [14]
Input unit

3) **Scanner** - It helps to convert content available on paper to digital image using a moving scan system.
4) **Tablet** - It converts whatever is written with fingers or a stylus to characters and images on screen.
5) **Light pen** - The device has a light sensitive tip which converts traces the features of display on CRT monitor and converts it to a new digital image.
Output unit

1) **Monitor (otherwise called Console Output Unit or Visual Display Unit (VDU))**

1. Cathode Ray Tube (CRT) monitors were used in the early days of computer.
2. Plasma (Ionized gas) monitors were also used with computers. But, they are now used for large panel televisions instead of computers. It is not economical to manufacture plasma monitors less than 32” in size.
3. Liquid Crystal Display (LCD), Light Emitting Diode (LED) and Thin Film Transistor (TFT) monitors are commonly used. LCD may be a bit dull compared to LED and TFT monitors.
4. Plasma, LCD, LED and TFT monitors consume lower power compared to the CRT monitors, occupy less space and present vivid range of colours.
5. The maximum permissible resolution for LCD and LED monitors is numerically limited but have sufficient resolution (PPI - Pixels Per Inch) to produce vivid images.
(a) CRT[18]  (b) LCD[20]  
(c) TFT[19]  (d) LED[21]

Figure: Types of monitor
Monitor resolution and aspect ratio

1) **Resolution of monitor** refers to the number of pixels (Picture Elements, dots) which can be placed on the display area.

2) **Aspect ratio** is ratio between the number of pixels in the horizontal direction to the number of pixels in the vertical direction.

3) The CRT monitors had aspect ratio of 4:3. Resolutions of 400x300 and 800x600 fall under the aspect ratio of 4:3.

4) Modern LCD, LED and TFT monitors have aspect ratios of 16:9, 16:10, etc. Modern monitors are called wide screen displays due to the higher width to height ratio. Resolution of 1920x1080 is the typical resolution for aspect ratio of 16:9 and 1280x800 is the typical resolution for aspect ratio of 16:10.

5) Monitor resolution may also be measured using Pixels Per Inch (PPI), which is the number of pixels in one inch distance of the monitor.

6) In monitor resolution, the term **High Definition (HD)** denotes the closely spaced pixels to produce clear display of images.
Monitor resolutions

Table: Monitor resolutions

<table>
<thead>
<tr>
<th>No.</th>
<th>Display Definition</th>
<th>Pixel resolution</th>
<th>Progressive Resolution</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Standard Definition (SD)</td>
<td>640×480</td>
<td>480p</td>
</tr>
<tr>
<td>2</td>
<td>High Definition (HD)</td>
<td>1280×720</td>
<td>720p</td>
</tr>
<tr>
<td>3</td>
<td>Full High Definition (FHD)</td>
<td>1920×1080</td>
<td>1080p</td>
</tr>
<tr>
<td>4</td>
<td>2k resolution</td>
<td>2048×1080</td>
<td>2k</td>
</tr>
<tr>
<td>5</td>
<td>4k resolution</td>
<td>3840×2160</td>
<td>4k/ ultra HD</td>
</tr>
</tbody>
</table>
2) **Printer:** Printer produces paper copies called hard copies. Following printers are available:

1. **Impact type printers:** Impact type printers hit the paper using characters and shapes to produce an imprint on the paper. Dot matrix printer, line printer, chain printer, golf ball printer, daisy wheel printer, etc. are examples of impact printers.

2. **Non-impact type printers:** Non-impact type printers do not physically hit the shapes and characters on the paper. Some of the most common types of non-impact printer are:
   
   (i) **Inkjet printer:** Inkjet printer uses ink cartridges and print head. The head spits ink in desired pattern to produced characters and shapes.

   (ii) **LASER printer:** Laser printer uses heat generated by LASER beam to create shapes/characters and make the toner powder to stick to the paper.

   (iii) **Thermal printer:** Thermal printer creates desired shapes and characters using heating filament on a special paper coated with BisPhenol A (BPA). It is used in ATM machines, ticketing machines, point of sale terminals, etc.

   (iv) **Plotter:** Plotter is a large printer (usually non-impact type) used to produce large size drawings on paper.
(a) DOT matrix printer[22]  (b) Line printer[23]  (c) Chain printer[24]
(d) Golf ball printer[25]  (e) Daisy wheel printer[25]
(a) Inkjet printer[27]  
(b) LASER printer[28]  
(c) Thermal printer[29]  
(d) Plotter[30]
Central Processing Unit

The processing centre of computer where mathematical and logical operations are carried out by the processor is called Central Processing Unit. The Central Processing Unit has the following internal components:

1. Microprocessor.
2. Main Memory or Primary Storage or Random Access Memory.
3. Mother board.
4. Secondary Storage or Auxiliary Storage (Hard disk, optical (CD/DVD) drive, floppy drive (obsolete).)
5. Switch Mode Power Supply (SMPS).
6. Connectors for storage and power controls.
7. Ports for connecting other devices.
Microprocessor

- Microprocessor is the chip that performs arithmetic and logical operations based on given input data and instructions and sends out the results of such processing operation.
- Microprocessor contains huge number of electronic devices like transistors, capacitors, resistors and inductors embedded in neatly etched circuitry.
- Microprocessor is the brain of computer since all other parts of computer simply coordinate with this one chip.
- Processor can complete one operation per clock cycle. The number of clock cycles per second is called the speed of the processor, measured in kHz (1 kHz = thousand cycles per second) or FLOPS (FLoating Point OPerations per Second).
- Registers in microprocessor hold the data required for processing.
Control unit of the microprocessor directs the work to be carried out by other parts of a computer. It coordinates with the memory registers and Arithmetic and Logic Unit to complete processing.

Arithmetic and Logic Unit (ALU) is the part of microprocessor circuitry which does the number crunching and comparison works.

Parallel processing in microprocessors is made possible through multiple processor cores cast in a single chip.

Multi-core processors gain higher speed if proper multi-processing algorithms are combined with multi-core processors.

Small memory called cache memory is etched on board the micro-processor.
(a) Pentium 4 Processor[33]
(b) Core 2 Duo Processor[34]
(c) Core i3 Processor[35]
(d) Core i5 Processor[36]
(e) Core i7 Processor[37]
(f) Athlon Microprocessor[38]
Main Memory or Primary Storage or Random Access Memory

- Main memory is the storage reserved for the data and instructions moving to and from the processor.
- Main memory is very fast.
- Main memory does not retain any data. It looses data when a program exits or when the computer is rebooted. Hence, it is called **Volatile storage** - the storage that evaporates.
- Main memory is otherwise called primary storage, volatile storage or the more common name of Random Access Memory (RAM).

![Common types of RAM](image)

(a) SDRAM[39]  (b) DDRSDRAM[40]

Figure: Common types of RAM
Different types of RAM are:

1. **SRAM**: Static Random Access Memory
2. **DRAM**: Dynamic Random Access Memory
3. **FPM DRAM**: Fast Page Mode Dynamic Random Access Memory
4. **EDO DRAM**: Extended Data Out Dynamic Random Access Memory
5. **SDRAM**: Synchronous Dynamic Random Access Memory
6. **DDR SDRAM**: Double Data Rate Synchronous Dynamic Random Access Memory
7. **RDRAM**: Rambus Random Access Memory
8. **VRAM**: Video Random Access Memory
9. **MPDRAM**: Multi-Port Dynamic Random Access Memory
10. **SGRAM**: Synchronous Graphics Random Access Memory
Mother board

- The board containing the electronic components needed for supporting the micro-processor (µP), RAM and other components is called the mother board.
- Mother board has slots for connecting secondary storage units like hard disk, CD drive, DVD drive, floppy disk, etc.
- Motherboard contains the Complimentary Metal Oxide Semiconductor - CMOS, which keeps configuration data needed at boot time. It is a RAM, but kept constantly powered on by a special battery called CMOS battery.
- Motherboard supports Basic Input Output System (BIOS), which helps booting of the computer (power up process).
- The motherboard supports Communication & Network Riser - (CNR), Accelerated Graphics Port (AGP), Parallel Advanced Technology Attachment (PATA) or Integrated Drive Electronics (IDE), Serial Advanced Technology Attachment (SATA), Northbridge chipset (for data transfer to and from the processor), Southbridge chipset (data transfer to and from peripherals/secondary storage units).
Figure: Motherboard[41]
Secondary Storage or Auxiliary Storage

- Secondary storage or auxiliary storage is very slow compared to the Random Access Memory, but it provides permanent storage for data.
- Data stored in secondary storage or auxiliary memory will be available even after the computer reboots.
- Hard disk, CD/DVD drive, floppy drive, etc. are some of the secondary storage units.
- Hard disk uses a magnetic plate mounted on motorized spindle to store and retrieve data.
- Compact Disk (CD) or Digital Versatile Disk (DVD) drive uses LASER beam of low strength for reading and high strength for writing data.
- Floppy disk is a magnetic film coated plastic plate which can store very small amount of data. Floppy disk is easily damaged and is no longer used in computers.
- Chip based storages like SD (Secure Digital) Card, Micro-SDCARD, PCMCIA (Personal Computer Memory Card International Association), pen drive, external hard disk, etc. are some of the portable data storage devices.
Read Only Memory

- Chip level storage, like the information stored in BIOS, is called Read Only Memory.

- Read only memory is classified as follows:
  1. **PROM - Programmable Read Only Memory:** Programmable Read Only Memory. It may be reprogrammed using PROM programmer, but only once.
  2. **EPROM - Erasable Programmable Read Only Memory:** Contents of EPROM may be erased using Ultra Violet (UV) rays and reprogrammed using RPROM programmer.
  3. **EEPROM - Electronically Erasable Programmable Read Only Memory:** Contents of EEPROM may be erased in the circuit where it is located and the same may be reprogrammed. BIOS chip belongs to EEPROM category.
Common storage sizes are presented in Table 3.

### Table: Memory sizes

<table>
<thead>
<tr>
<th>Sl. No.</th>
<th>Storage name</th>
<th>Storage size</th>
<th>Remarks</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Bit</td>
<td>1 bit</td>
<td>Smallest size memory. Stores 0 or 1</td>
</tr>
<tr>
<td>2</td>
<td>Nibble</td>
<td>4 bits</td>
<td></td>
</tr>
<tr>
<td>3</td>
<td>Byte</td>
<td>8 bits</td>
<td>Smallest allocation unit through programs.</td>
</tr>
<tr>
<td>4</td>
<td>kilo Byte (kB)</td>
<td>1024 bytes</td>
<td>$2^{10} \times (1024)$ bytes</td>
</tr>
<tr>
<td>5</td>
<td>Mega Byte (MB)</td>
<td>1024 kilo bytes</td>
<td>$2^{20} \times (1048576)$ bytes</td>
</tr>
<tr>
<td>6</td>
<td>Giga Byte (GB)</td>
<td>1024 mega bytes</td>
<td>$2^{30} \times (1073741824)$ bytes</td>
</tr>
<tr>
<td>7</td>
<td>Tera Byte (TB)</td>
<td>1024 Giga bytes</td>
<td>$2^{40} \times (1099511627776)$ bytes</td>
</tr>
<tr>
<td>8</td>
<td>Peta Byte (PB)</td>
<td>1024 Tera bytes</td>
<td>$2^{50} \times (1125899906842624)$ bytes</td>
</tr>
<tr>
<td>9</td>
<td>Exa Byte (EB)</td>
<td>1024 Peta bytes</td>
<td>$2^{60} \times (1152921504606846976)$ bytes</td>
</tr>
</tbody>
</table>

### Table: Storage capacities for computer media (secondary storage)

<table>
<thead>
<tr>
<th>Sl. No.</th>
<th>Media</th>
<th>Storage capacity</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>CD</td>
<td>700MB</td>
</tr>
<tr>
<td>2</td>
<td>DVD</td>
<td>4.7GB</td>
</tr>
<tr>
<td>3</td>
<td>SD/ Mini-SD/ Micro-SD card</td>
<td>2GB to 128GB</td>
</tr>
<tr>
<td>4</td>
<td>Pen drive</td>
<td>2GB to 128GB</td>
</tr>
<tr>
<td>5</td>
<td>Hard disk</td>
<td>250GB to 1TB</td>
</tr>
</tbody>
</table>
(a) Hard drive
(b) CD/DVD drive
(c) Floppy drive
(d) Pen drive
(e) SD, Mini SD and Micro-SD cards
Switch Mode Power Supply (SMPS)

- Switch Mode Power Supply (SMPS) takes 240V input and converts it to varying levels of output to suit the requirements of different components of the CPU.
- SMPS is very efficient in power conversion and minimizes wastage of electricity.
- SMPS produces radio frequency interference, which affects communication signals in the radio frequency (mobile phone, radio receiver, etc.).

Figure: Switch Mode Power Supply (SMPS)
CPU ports

- Ports are located at the rear panel of CPU.
- Ports help connection of various peripherals (like keyboard, mouse, printer, scanner, camera, speaker, microphone, audio-input, monitor, serial modem, broadband line, etc.) to the computer.

- Some of the most common ports are: (i) PS/2 (Personal System 2) ports for keyboard and mouse; (ii) RS-232 (Recommended Standard 232)/ Serial port for mouse, modem and other serial devices; (iii) VGA (Video Graphics Array) port for connecting monitor or projector; (iv) Ethernet / RJ-45 (Registered Jack 45) for broadband connection; (v) USB (Universal Serial Bus) port for connecting printer, fax, pen drive, external hard disk, external DVD writer, web camera, etc.; (vi) LPT (Line Printer Terminal) port for connecting old style dot matrix/ line printers; (vii) 3.5mm audio jack for speaker output/ mic input; (viii) Game port - port for connecting joystick.
Figure: Ports in CPU
Common terms related to computer hardware

1) **CPU**: Central Processing Unit
2) **PS2**: Personal System 2
3) **USB**: Universal Serial Bus
4) **RS-232 (Serial) port**: Recommended Standard 232
5) **LPT (Parallel) port**: Line Print Terminal
6) **VGA**: Video Graphics Array
7) **RJ-45**: Registered Jack 45. Other names: Ethernet port or LAN Port. LAN stands for Local Area Network. Used for broadband connection.
8) **RJ-11**: Registered Jack 11. Used for connecting telephone line or networking through telephone line.
9) **DVI**: Digital Visual Interface.
10) **HDMI**: High Definition Media Interface.
11) **SMPS**: Switch Mode Power Supply.
12) **HDD**: Hard Disk Drive.
Common terms related to computer hardware

13) **FDD**: Floppy Disk Drive.

14) **SATA**: Serial Advanced Technology Attachment.

15) **PATA**: Parallel Advanced Technology Attachment. Otherwise called Parallel port or IDE port.

16) **IDE**: Integrated Device Electronics. This is an alternate name for PATA.

17) **RAM**: Random Access Memory. Otherwise called Primary storage or main memory or volatile memory.

18) **CMOS**: Complimentary Metal Oxide Semi-conductor.

19) **BIOS**: Basic Input Output System.

20) **CNR**: Communication and Network Riser.

21) **IEEE 1394**: Institute of Electrical and Electronics Engineers 1394. Otherwise called Firewire port.

22) **ATA**: Advanced Technology Attachment.

23) **ATX**: Advanced Technology eXtension.

24) **DDR**: Double Data Rate.
Computer software

- Computer software decides how the hardware works.
- Software is the reason why computers can produce output based on given input.
- Software can be divided into 2 essential categories:
  1. **System software:** The software needed for by the computer to support other software and hardware components is called the system software. The Basic Input Output System (BIOS), the Operating System (Windows, Unix, Linux, Mac OS, etc.) and device drivers are the major system software. System software does not directly carry out any productive work (like document editing). It helps other software packages to work and produce desired output through available hardware.
  2. **Application software:** Application software helps in productive working of computer like creating documents, spreadsheets, playing music/video, managing databases, etc.. It does not worry about booting the computer or controlling the hardware (these works are relegated to the system software).
Functions of an operating system

1) Operating system coordinates with BIOS in identifying hardware available at the time of booting.

2) Operating system initializes, operates and controls all peripheral units through appropriate drivers.

3) Operating system coordinates application programs and allows time sharing or parallelism. Parallel processing helps several applications to run concurrently through sharing of the processor time. Users feel as if all the applications are running continuously in the background and foreground.

4) Operating system allots, manages and frees memory needed for other processes.
Functions of an operating system

5) Operating system makes secondary storage devices to load and save data.

6) Operating system manages network connections and shares available connection between programs needing network access.

7) Operating system manages hard disk fragmentations and tries to arrange storage tracks in continuous chunks.

8) The core of the operating system, handling hardware, file system and networking is called the *kernel* of the operating system.

9) The part of the operating system which interacts with the user is called *shell* of the operating system. Shell can provide command line interface or Graphical User Interface (GUI).
Popular Operating Systems in use

Following are the most popular operating systems on computers:

1. Microsoft Windows
2. Apple Mac OS
3. Linux
4. UNIX
5. Free BSD, Darwin, BeOS, Solaris, IBM AIX, etc.
Microsoft Windows

- Microsoft Disk Operating System (MSDOS) released in 1981. Development of MS DOS was stopped in the year 2000.

- MS DOS based Windows 1.0 was released by Microsoft in 1985. After Windows 3.1, subsequent releases were named Windows 95, Windows 98, Windows Me. The MSDOS based Windows were discontinued.

(a) Windows 10

(b) Windows 10 Mobile

Figure: Windows 10
Mac OS

- Apple computers released the first version of a Mac OS in the year 1984.
- It was the first operating system to have a Graphical User Interface (GUI) on commercial computers.
- Mac OS is available only on Mac computers.
- The latest version of Mac OS is Mac OS.
- The present Mac OS is based on a free UNIX kernel named "Darwin".
- Mobile version of the Mac OS is called iOS and is installed in Apple iPhone, iPad, iPod and iWatch.
(a) Mac OS[49] 
(b) iOS 

Figure: Mac OS and iOS
Linux

- Linux was developed by Linus Torvalds in the year 1991.
- Linux is distributed under the GNU General Public License (GNU GPL), which permits free access to source code, but mandates redistribution of software under the same license.
- Linux operating system was inspired by Unix operating system.
- Linux provides a stable, scalable, highly productive kernel.
- Linux kernel supports several Graphical User Interfaces like GNOME (GNU Network Object Model Environment), KDE (K Desktop Environment) and Enlightenment. The user may choose a convenient desktop environment.
- Linux has been modified by several agencies to run on mobile devices. Android (by Google Inc.), Firefox OS (by Firefox Inc.) and Tizen (by Independent Software Vendors lead by Samsung) are some of the customized versions of Linux for mobile phones, smart watches, tablets and other devices.
- Linux supports Bourne Again Sheel (bash), Korn Shell (ksh), C Shell (csh), etc. for command line interface. These shells provide powerful functionality for the Linux command line.
(a) GNOME on Linux[49]

(b) KDE on Linux[?]
Figure: Mobile versions of Linux

(a) Android

(b) Firefox OS[53]

(c) Tizen[54]
UNIX

- UNIX was one of the first operating systems to support multi-tasking and multiple user logins.
- UNIX was developed at AT&T Bell Labs in the year 1970 by Ken Thompson, Dennis Ritchie, M. D. McIlroy and J. F. Ossanna and others.
- UNIX still remains the gold standard for any operating system. The UNIX operating system was standardized by POSIX (Portable Operating System Interface), which was superceded by SUS (Single Unix Standard).
- Hence, any operating system complying with SUS may be called UNIX. Apple Mac OS X, HP UX, IBM AIX, IBM Z/OS Oracle Solaris, Inspur K-UX are some of the SUS compliant operating systems.
- Notable non-entrants to the SUS compliant list are Linux and BSD Unix. The non-compliance is attributed to the cost of registration or providing alternate implementations to the specifications of POSIX/SUS.
- Unix supports several shell environments like Bourne Shell.
Figure: Common Desktop Environment (CDE) on UNIX
Overview of operating systems

- By market share, Microsoft Windows is the most common operating system used in personal computers.
- Apple computers installs Mac OS X in its computers. This operating system presents a Graphical User Interface (GUI) and good security. Mac OS High Sierra is the latest version of Mac.
- Free operating system named Linux is available for variety of computers from desktops to servers. Linux kernel has been repacked with a variety of features in the names of Debian, Ubuntu, Red Hat, Fedora, SUSE, etc. are some of the popular versions of Linux.
- Many more operating systems like BeOS, FreeBSD, Darwin, etc., are also used on computers.
Main features of Windows O.S.

1) Windows is based on a graphical user environment called Desktop.
2) The desktop contains a collection of icons, named *desktop icons or shortcut icons*.
3) Windows provides a *taskbar*. The Taskbar contains start menu, quick launch icons and the system tray.
4) The start button opens a list of applications which can be run by clicking on their names or icons. Usually, start button appears at the left most end of task bar.
5) Quick launch icons are provided near the start button. They offer shortcuts to frequently used programs.
6) System tray provides status of several background tasks, data and time, volume control (optional) and network connectivity icon. The system tray is a quintessential control panel for background programs.
7) Clicking any icon in the desktop area or quick launch bar opens the corresponding application.
8) The list of processes currently running in the foreground is displayed at the centre portion of the taskbar.
Directory structure

1) Windows provides a directory named *user* (also called *Documents and Settings*) in the root folder of C: drive.

2) The user folder contains sub-folders representing the name of each user who logs in. In addition to individual sub-folders, a sub-folder named Public is available, the contents of which are shared with all users.

3) The sub-folder named after the individual user is called the *Home* folder. E.g., a person having login name *krish* gets a home folder called *C:\users\krish*.

4) Within the home directory, folder named *Desktop* stores all items seen in the desktop, *Documents* saves all files created by the user, *Downloads* saves all files downloaded from the Internet, *Pictures* stores all image files, *Videos* saves all video files, folder named *Music* saves all music files.
Default programs in Windows installation

1) For displaying images, *Windows Image Viewer* is installed by default. It can display images, print images and start move through the images on pressing the navigation keys.

2) For playing audio and video, *Windows Media Player* is available.

3) For editing plain text files, *Notepad* is available.

4) For editing Rich Text File (RTF) documents, *Wordpad* or *Writer* is available.

5) For creating videos out of photos and for editing videos, *Windows Movie Maker* is available.

6) Accessibility items like screen magnifier, onscreen keyboard and screen reader are available by default.

7) For browsing web pages, *Internet Explorer* is available.

8) For creating, cutting, copying, pasting, renaming files, *Windows Explorer* or *My Computer* is available.

9) **Microsoft Office** is not available by default in Windows. The packages should be bought and installed separately.
Features of Windows Explorer

► Windows Explorer may be opened from the start menu or by pressing *Windows button* + E.

► To rename a file, right click on the file (or select the file and press F2). The name file becomes editable.

► To copy a file, right click and choose copy (or press Ctrl+C). Press Ctrl+V at the new destination where a copy of the original file is needed.

► To cut a file (make a copy file and remove the original file), right click and choose cut (or press Ctrl+X). Press Ctrl+V at the new destination where a copy of the original file is needed. After copying, the original file will be deleted.

► To open a document, spreadsheet, music file, video file or any other file having a known support application (like MS Word, Excel, Windows Media Play/VLC), simply open the file by double clicking (or single click if enabled).
- To create desktop shortcut to a file, right click on the file, choose Send to → Desktop (create shortcut).

- To burn a file to CD/DVD, right click the file, choose Send to→ X: <CD/DVD Drive name>. The file writing dialog will appear when a blank CD/DVD is inserted. Follow on screen instructions to complete the process.

- To compress a file, right click, choose Send to → Compressed/Zipped archive. The file will be compressed. If a third party zipping program like WinZip or WinRAR is installed, separate entries will be available for zipping.

- To unzip a compressed archive, simply double click the archive. Otherwise, right click the archive and choose appropriate option for unzipping.

- Large files can be compressed into smaller size with the help of zipping. WinRAR provides support for splitting a file into chunks (which can be combined at a new location) of specified size (to fit a CD/DVD).
Shortcut keys in Windows

- **F1** - Windows help.
- **F2** - Rename.
- **F3** - Find all files.
- **F5** - Refresh current window.
- **F6** - Move among panes in Windows Explorer.
- **Windows + L** - Lock computer.
- **Windows + M** - Show desktop.
- **Windows + D** - Show desktop.
- **Windows + R** - Run a command.
- **Windows + P** - Display sharing (with projector, secondary monitor, etc.).
- **Windows + V** - start clipboard.
- **Windows + K** - Audio/ video sharing.
- **Windows + I** - Windows settings.
- **Windows + A** - Alerts/ notifications.
- **Windows + S** - Open cortana.
- **Windows + F** - Windows feedback.
- **Windows + E** - Open Windows Explorer.
...Shortcut keys in Windows

► **Alt+F4** - Close current program/shutdown Windows.
► **Alt+Tab** - Cycle through currently running processes.
► **Alt+Down arrow** - Pop down list.
► **Alt+Space** - Window’s system menu.
► **Alt+-** - System menu for child window.
► **Alt+Enter** - properties of the selected object.
► **Alt+Left arrow** - Previous folder in Windows Explorer.
► **Shift+Delete** - Delete permanently.
► **Shift+F10** - Context menu; equivalent to right click.
► **SHIFT** - Disable autorun for newly inserted media.
► **Ctrl+F4** - Closes the current child window.
► **Ctrl+X** - Cut a file.
► **Ctrl+C** - Copy a file.
► **Ctrl+V** - Paste a file.
► **Ctrl+Esc** - Start menu.
► **Ctrl+Shift+Esc** - Task Manager.
Using Scanner, printer and webcam

- To make a peripheral unit like scanner, printer or webcam, the appropriate device driver should be installed.
- Device driver is a special software to help the operating system access a peripheral unit.
- After installing the device driver, the operating system may require a reboot to detect the device.
- Scanner becomes accessible from MS Paint, Photoshop, GIMP or any other image processing software. Place the document to be scanned on the glass bed and operate the scanner using the software to acquire scanned copy.
- Any printer whose device driver has been installed may be chosen at the time of printing. Simply select the right paper type and paper size to get good results by pressing properties button adjacent to the printer name.
- Webcam is normally used to create a video. It is used for video conferencing, Internet Telephony (VOIP - Voice Over IP), etc. Webcam may be rarely used for taking photos. But the still images are from webcam are very hazy (blurred).
Introduction to the booting process, BIOS settings and their modification. Introduction to various types of memories and their features. Basic Hardware and software issues and their solutions. Formatting and Loading O.S., application software and antivirus.
Booting process of computer

- Booting is the process of hardware waking up and getting ready to load the operating system (Windows, Linux, Mac OS X, etc.).
- When the computer boots, the BIOS (Basic Input Output System) activates a series of hardware checkes called Power On Self Test (POST).
- The BIOS reads essential settings like date, time and boot device order, as customized by the user, from the CMOS.
- BIOS initializes all devices (disc drives, video cards, sound cards, network cards, floppy drives, USB ports and hard drives) connected to the computer.
- BIOS later works with the processor to transfer data to and from those devices.
- The programs needed for BIOS routines are stores in a BIOS chip.
Booting process of computer

▶ On successful completion of the POST routines, the *boot loader* loads the operating system from specified boot device (hard disk, DVD ROM, CD ROM, etc.).

▶ The boot loaded initially loads from a chip and is called *Primary Boot Loader*. The primary boot loader then calls a more elaborate boot loader program called *Secondary Boot Loader*.

▶ The secondary boot loader is normally stored in Master Boot Record (MBR). GNU GRUB, BOOTMGR, NTLDR, UEFI (Unified Extensible Firmware Interface) or ESP (EFI system partition).)

▶ The secondary boot loader, loads the operating system. When the operating system finishes loading, booting is complete and the computer is ready for usage.

▶ The computer beeps when the POST routines are successfully completed. It beeps and error message if there is some failure of POST.
Booting process of computer

▶ In case the POST fails, codified beeps are issued to denote the type of error encountered during POST. The beep codes and messages are as follows:

1. **Steady, short beeps**: Power supply may be bad
2. **Long continuous beep tone**: Memory failure
3. **Steady, long beeps**: Power supply bad
4. **No beep**: No power supply or beeper damaged.
5. **One long, two short beeps**: Video card failure
BIOS settings

- BIOS is the Basic Input Output System in computer.
- Settings needed for BIOS are stored in CMOS (a RAM chip).
- CMOS is kept continuously power on using a special battery called CMOS battery (model No.CR2032).
- When CMOS battery fails or is removed, all settings stored in CMOS are lost.
- BIOS settings may be accessed by pressing DEL, F2, ESC, or any other key (depending on the manufacturer) immediately after switching on the power supply.
The BIOS settings may be classified under the following heads:

1. **Main**: Settings related to date, time, drive options, memory details, etc.
2. **Advanced**: Configuration of processor, on board features of the motherboard, configuration of USB, etc. can be accessed through Advanced option.
3. **Power**: Power options relate to the options to deal with power off and subsequent restart, suspension of disk drive after particular duration, etc.
4. **Boot**: The options relating to UEFI, order of the boot devices and options to change boot order, etc. are displayed in boot settings.
5. **Security**: The options related to setting of user and administrator passwords is available from Security menu.
6. **Exit**: Options for saving the settings before exit, load optimal defaults before exit, load previous settings that worked, discard all changes and exit the CMOS settings, etc. are displayed under this menu.
Phoenix - AwardBIOS v6.00PG, An Energy Star Ally
Copyright (C) 1984-2008, Phoenix Technologies, LTD

K987PV-PLUS-FRO

Main Processor: AMD Athlognm(tm) XP 3200+
CPU Temperature Protection is ON
Memory Testing : 4096000K OK
Memory Clock is: 166MHz (DDR333)
Detecting IDE drives ...

Press DEL to enter SETUP
06/18/2007-KT440-1523-8E6LY7299C-00

Figure: Message to access BIOS settings
Figure: BIOS - Main settings
Figure: BIOS - Advanced settings
Figure: BIOS - Boot settings
Figure: BIOS - Security settings
Figure: Message for booting from CD

Press any key to boot from CD...
Installation of Windows operating system

▶ Power on the computer, place the installation media (CD, DVD or pen drive) in the appropriate drive.
▶ Modify boot device order and make either ATAPI (Advanced Technology Attachment Packet Interface) drive or USB media as the first boot device.
▶ On detecting Windows boot media, a message is displayed seeking to press any key to boot from that media.
▶ Press any key on the keyboard to initiate the boot process of Windows for new installation.
▶ Windows takes some time to load from the media. It displays language selection screen and keyboard layout for use during installation. Press **Next** button.
▶ The menu for managing hard disk partitions is displayed. Press delete or add partitions to suite the requirements. New partitions can be formatted to erase previous data contained in them.
Installation of Windows operating system

- Choose the partition for installation of Windows and press **Next** button.
- Windows takes a while, copies and installs required files and reboots.
- During this reboot, do not press any key until the new Windows loads. Otherwise, we may end up repeating the first few steps again and again.
- Windows asks for serial number for authentication. Enter valid serial number provided during purchase of the Windows installation media.
- Windows prompts to enter user names and passwords for login.
- Windows may prompt for a few other configurations before displaying the opening screen.
- Login and start using Windows (Application software like MS Office, Adobe reader, etc. should be installed subsequently).
Basic Hardware and software issues and their solutions

1) **Brute solution to many problems:** Reboot the computer. It solves several problems without going through the details. So, restart is the first solution to fix problems in a running computer.

2) **Computer is slow:** Remove Internet connection. Run disk cleanup from control panel. Open task manager (run taskmgr, press Ctrl+Shift+Esc, or press Ctrl+Alt+Delete and choose task manager), right click unwanted programs and choose End Process.

3) **Computer misbehaves:** Remove all peripherals. Connect just monitor, keyboard and mouse. Boot PC to know whether problems recurs. Add all other peripheral units one by one. Identify whether the problem occurs due to any particular peripheral.

4) **PC does not boot:** Reconnect/ replace power cables. Check whether SMPS is running (SMPS switch turned on and fan running in the rear panel). Check whether motherboard LED is lit up.
5) **Long beeps & boot halted:** Remove RAM chip. Clean the RAM canal and the ram chip. Reinsert the chip.

6) **Insert boot media error:** Open BIOS settings. Arrange boot devices in right order. Reboot. If problem persists, see whether the required media is listed in the BIOS. Boot from alternate media (like CD, DVD or pen drive) to check whether the PC can boot at all.

7) **Boot halted due to wrong settings:** Press Del or F2 or enlisted key to access BIOS. Set correct date and time.

8) **PC does not switch on:** Check power cables. Check SMPS.

9) **BIOS settings are lost after each poweroff:** Replace CMOS battery (CR2032).

10) **Printers do not work:** Open control panel. Go to services. Click on *Print Spooler* service. If it is not running (most probable), start the service.
11) **PC Reboots while working:** Try another RAM. If problem persists, try another SMPS. Check all IDE/ SATA cables. Reinsert all power cables.

12) **Internet connection is slow:** See whether Windows is automatically downloading updates. Pause the updates and check connection speed (Automatic updates may be disabled using control panel).

13) **Cannot install new program:** Right click on setup file and choose *Run as administrator*. If it does not solve the problem, choose compatible installer (32 bit or 64 bit) for the operating system.

14) **Paper jam error:** Switch off printer. Remove top cover. Remove jammed paper. Power on the printer and check whether it works.
Introduction to basic DOS Internal and External Commands. Introduction to Open Source Software. Introduction to Linux Operating System features, structure, files and processes. Introduction to various Linux Shells. Basic Linux commands.
Introduction to basic DOS

► MS DOS was a small operating system released by Microsoft Corporation in the year 1981 to run on IBM Personal Computer.

► After releasing version 8.0 in September 2000, development work on MS DOS ceased.

► MS DOS applications had either .COM extension or .EXE extension.

► MS DOS supports two types of commands:
  (i) **Internal DOS commands** - the commands which were part of the DOS os and loaded to memory, whether called for or not. These commands are also called **Memory Resident DOS Commands**.
  (ii) **External DOS commands** - the commands which were kept in disk and loaded only when invoked from the command prompt.

► A collection of DOS commands may be typed inside a file (typically beginning with `@echo off`) having .BAT extension (called a batch file). The batch file can be invoked as a new command.
## Internal DOS commands

<table>
<thead>
<tr>
<th>Command</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>1 CLS</td>
<td>Clear screen.</td>
</tr>
<tr>
<td>2 DIR</td>
<td>Show list of files and directories.</td>
</tr>
<tr>
<td>3 VER</td>
<td>Show version number of MS DOS.</td>
</tr>
<tr>
<td>4 VOL</td>
<td>Show volume label for a disk drive.</td>
</tr>
<tr>
<td>5 DATE</td>
<td>Show current date; set new date if necessary.</td>
</tr>
<tr>
<td>6 TIME</td>
<td>Show current time; set new time if necessary.</td>
</tr>
<tr>
<td>7 COPY</td>
<td>Create copy of one file to another file.</td>
</tr>
<tr>
<td>8 TYPE</td>
<td>Display contents of a file in the command window.</td>
</tr>
<tr>
<td>9 COPY CON</td>
<td>Copy the typed content to a file name provided in as argument. Copying stops when Ctrl+Z (end of file indicator) is pressed.</td>
</tr>
<tr>
<td>10 REN</td>
<td>Rename the file (first argument - old name; second argument - new name).</td>
</tr>
<tr>
<td>11 DEL or ERASE</td>
<td>Delete a file.</td>
</tr>
<tr>
<td>12 MD or MKDIR</td>
<td>Create new directory.</td>
</tr>
<tr>
<td>13 CD or CHDIR</td>
<td>Change to new working directory.</td>
</tr>
<tr>
<td>14 RD or RMDIR</td>
<td>Remove given directory.</td>
</tr>
</tbody>
</table>
15  ECHO Takes on or off argument to decide whether commands file batch file are displayed or not.
16  EXIT Closes command prompt.
17  PATH Displays list of directories in which a command is looked for. Sets new path if necessary.
18  PAUSE Hold on processing until Enter key is pressed.
19  PROMPT Set new command prompt instead of \ >
20  REM Remarks.
21  SET Set new values for an environment variable.
## External DOS commands

<table>
<thead>
<tr>
<th></th>
<th>Command</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>APPEND</td>
<td>Adds given directories to the end of PATH environment variable.</td>
</tr>
<tr>
<td>2</td>
<td>ASSIGN</td>
<td>Change given drive name to a new drive letter.</td>
</tr>
<tr>
<td>3</td>
<td>ATTRIB</td>
<td>Change attributes (a-archive, h-hidden, r-read only, s-system file).</td>
</tr>
<tr>
<td>4</td>
<td>BACKUP</td>
<td>Backup specified files to given destination.</td>
</tr>
<tr>
<td>5</td>
<td>CHKDSK</td>
<td>Check the disk for errors and rectify errors.</td>
</tr>
<tr>
<td>6</td>
<td>COMMAND.COM</td>
<td>MS DOS operating system program.</td>
</tr>
<tr>
<td>7</td>
<td>COMP</td>
<td>Compare two files. Report first mismatch.</td>
</tr>
<tr>
<td>8</td>
<td>DEBUG</td>
<td>Debug given program. One can examine values store in variables.</td>
</tr>
<tr>
<td>9</td>
<td>DISKCOMP</td>
<td>Compare 2 disks with each other.</td>
</tr>
<tr>
<td>10</td>
<td>DISKCOPY</td>
<td>Copy contents of one disk to another.</td>
</tr>
<tr>
<td>11</td>
<td>DOSKEY</td>
<td>Store command history.</td>
</tr>
<tr>
<td>12</td>
<td>DOSSHEL</td>
<td>A visual shell for exploring files and directories.</td>
</tr>
<tr>
<td></td>
<td>Command</td>
<td>Description</td>
</tr>
<tr>
<td>---</td>
<td>----------</td>
<td>--------------------------------------------------</td>
</tr>
<tr>
<td>13</td>
<td>EDIT</td>
<td>MS DOS Editor.</td>
</tr>
<tr>
<td>14</td>
<td>EDLIN</td>
<td>Edit single line.</td>
</tr>
<tr>
<td>15</td>
<td>EXPAND</td>
<td>Decompress files.</td>
</tr>
<tr>
<td>16</td>
<td>FC</td>
<td>Compare 2 files.</td>
</tr>
<tr>
<td>17</td>
<td>FDISK</td>
<td>Create disk partitions.</td>
</tr>
<tr>
<td>18</td>
<td>FORMAT</td>
<td>Format specified partition.</td>
</tr>
<tr>
<td>19</td>
<td>HELP</td>
<td>Display help about MS DOS commands.</td>
</tr>
<tr>
<td>20</td>
<td>LABEL</td>
<td>Display disk label.</td>
</tr>
<tr>
<td>21</td>
<td>VOL</td>
<td>Display volume details.</td>
</tr>
<tr>
<td>22</td>
<td>MEM</td>
<td>Display memory usage details.</td>
</tr>
<tr>
<td>23</td>
<td>MIRROR</td>
<td>Create backup file named MIRROR.FIL at root directory to restore lost information, if any, at a later date.</td>
</tr>
<tr>
<td>24</td>
<td>MORE</td>
<td>Show given information in small chunks for easy reading. Pressing a key moves forward. Pressing $&lt; \text{space} &gt;$ shows next page, $&lt; \text{enter} &gt;$ shows next line, $=$ shows line number, Q quits.</td>
</tr>
</tbody>
</table>
## External DOS commands

<table>
<thead>
<tr>
<th>Command</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>25 MOVE</td>
<td>Create a new file having contents of the old file, but delete the old file.</td>
</tr>
<tr>
<td>26 PRINT</td>
<td>Send given file to the printer. Check and correct errors in the file system of given drive. Works similar to CHKDSK command.</td>
</tr>
<tr>
<td>27 SCANDISK</td>
<td>Sort given input lines in alphabetic order.</td>
</tr>
<tr>
<td>28 SORT</td>
<td>/R option sorts in reverse order (Z to A or 9 to 0).</td>
</tr>
<tr>
<td>29 SYS</td>
<td>Make given disk bootable. It should be issued from C: drive.</td>
</tr>
<tr>
<td>30 TREE</td>
<td>Display files and directories in tree structure.</td>
</tr>
<tr>
<td>31 UNDELETE</td>
<td>Restore recently deleted file.</td>
</tr>
<tr>
<td>32 XCOPY</td>
<td>Extended copy mode for copying directories, subdirectories and files.</td>
</tr>
</tbody>
</table>
Output redirection in MS DOS

1  >  Write the output of the left side program to the file provided on the right side. If the file does not exist, it is created. If the file already exists, its contents are deleted.

2  >>  Write the output of the program on the left side to the file indicated on the right. If the file does not exist, it is created. If it exists, new content is appended to the end of file.

3  |  Pipe symbol. Pass the output of the program on the left to that on the right of the pipe.
Special characters in MS DOS

1  *  Match any number of characters.
2  ?  Match any one character.
Introduction to Open Source Software

- Open source software denotes software for which the original source code is available (not necessarily free of cost).
- Open source software helps capable users to correct bugs or add new features to the software.
- Open source model of software development enabled developers across the world to contribute to the improvement of a software.
- Open source model opposes the closed source monopoly of large corporates.
- Advent of open source software paved the way for creation of valuable software like Linux operating system, Mozilla Firefox browser, Open Office software package, GIMP image editor, QCAD drafting & design software, Blender 3D modelling and animation software, etc.
Introduction to Open Source Software

- Some of the software licenses which adopt open source licensing system are: Apache License, BSD license, GNU General Public License, GNU Lesser General Public License, MIT License, Eclipse Public License and Mozilla Public License.
- Richard Stallman created the GNU (GNU Not Unix) project.
- Linus Torvalds released the Linux operating system in 1991. Source code for Linux was distributed under the GNU General Public License.
Basic Linux commands

- Linux operating system contains 2 essential components, (i) the kernel which controls the computer peripherals, (ii) the shell, which transmits commands issued by the user to the kernel for processing.

- Linux commands may also be typed inside a text file and used as a new command. Such text file is called shell script.

- Several shells are available for interaction with the Linux kernel. Some of the most common shells are: (i) sh - Bourne Again Shell or bash, #!/bin/sh at the beginning of shell script denotes bash script. (ii) csh - C shell. It supports conditions and loops features similar to C programming language. (iii) ksh - Korn Shell. Korn shell was released as an improvement to the Bourne shell by AT&T Bell Labs.
Basic Linux shell commands

1. `ls`  List files and folders.
2. `mkdir`  Make directory having given name.
3. `rmdir`  Remove directory having given name.
4. `cp`  Copy given file to new name.
5. `mv`  Move given file to new name.
6. `cd`  Change directory.
7. `cd ..`  Change to parent directory.
8. `cd ~`  Change to home directory.
9. `cd /`  Change to root directory.
10. `mount`  Mount a file system/drive.
11. `umount`  Unmount a file system/drive.
12. `eject`  Eject a drive.
13. `shutdown -r < time >`  Restart the computer after given time.
14. `shutdown -h < time >`  Halt the computer after given time.
15. `sleep`  Stop processing work for given duration.
16. `sort`  Sort given input.
<table>
<thead>
<tr>
<th>No.</th>
<th>Command</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>17</td>
<td>ln</td>
<td>Create a link to the original file.</td>
</tr>
<tr>
<td>18</td>
<td>tar</td>
<td>Tape archive. Create an archive.</td>
</tr>
<tr>
<td>19</td>
<td>zip (or) gzip</td>
<td>Zip a file.</td>
</tr>
<tr>
<td>20</td>
<td>unzip (or) gunzip</td>
<td>Decompres given file.</td>
</tr>
<tr>
<td>21</td>
<td>ls -l</td>
<td>long list of files.</td>
</tr>
<tr>
<td>22</td>
<td>more</td>
<td>Display screenfulls of output.</td>
</tr>
<tr>
<td>23</td>
<td>less</td>
<td>Display screenfulls of output.</td>
</tr>
<tr>
<td>24</td>
<td>find</td>
<td>Search for a file having given name from given directory.</td>
</tr>
<tr>
<td></td>
<td>find . -name temp.txt -exec ls -l {}</td>
<td>search for a file named temp.txt from the current directory(.). Execute the command ls -l on the resulting file({}).</td>
</tr>
<tr>
<td>25</td>
<td>banner</td>
<td>Display given text in banner format.</td>
</tr>
<tr>
<td>26</td>
<td>rm</td>
<td>Remove a file.</td>
</tr>
<tr>
<td>27</td>
<td>cat</td>
<td>display contents of a file on screen.</td>
</tr>
<tr>
<td>28</td>
<td>cat - &gt;</td>
<td>Store keyboard input to a new file.</td>
</tr>
<tr>
<td>29</td>
<td>cat - &gt;&gt;</td>
<td>Append keyboard input to given file.</td>
</tr>
<tr>
<td>30</td>
<td>date</td>
<td>Display and set current date and time.</td>
</tr>
</tbody>
</table>
### Basic Linux shell commands

<table>
<thead>
<tr>
<th>Command</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><code>cc</code></td>
<td>Run C-language compiler.</td>
</tr>
<tr>
<td><code>vi</code></td>
<td>Open VI text editor.</td>
</tr>
<tr>
<td><code>emacs</code></td>
<td>Open emacs text editor.</td>
</tr>
<tr>
<td><code>gedit</code></td>
<td>Open gedit text editor.</td>
</tr>
<tr>
<td><code>useradd</code></td>
<td>Create new user. Works in super user mode.</td>
</tr>
<tr>
<td><code>userdel</code></td>
<td>Deletes given user name.</td>
</tr>
<tr>
<td><code>passwd</code></td>
<td>Changes password of the given user.</td>
</tr>
<tr>
<td><code>su</code></td>
<td>Increase privileges to super user level.</td>
</tr>
<tr>
<td><code>sudo</code></td>
<td>Run given command with super user privilege.</td>
</tr>
<tr>
<td><code>cal</code></td>
<td>Display calendar.</td>
</tr>
<tr>
<td><code>calc/ bc</code></td>
<td>Calculator.</td>
</tr>
<tr>
<td><code>cron</code></td>
<td>Run given programs as per scheduled timings.</td>
</tr>
<tr>
<td><code>awk</code></td>
<td>Interpreted language and filter for text handling.</td>
</tr>
<tr>
<td><code>sed</code></td>
<td>Stream editor and filter for text handling.</td>
</tr>
<tr>
<td><code>which</code></td>
<td>Find full path of given command.</td>
</tr>
<tr>
<td><code>file</code></td>
<td>Display file type of the argument.</td>
</tr>
</tbody>
</table>
## Basic Linux shell commands

<table>
<thead>
<tr>
<th>Command</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><code>tr</code></td>
<td>Substitute given character in place of unwanted one.</td>
</tr>
<tr>
<td><code>chown</code></td>
<td>Change ownership of file.</td>
</tr>
<tr>
<td><code>chmod</code></td>
<td>Change file access mode for owner, group and world. 1-read, 2-write, 4-execute.</td>
</tr>
<tr>
<td><code>groupadd</code></td>
<td>Create a new group.</td>
</tr>
<tr>
<td><code>groupdel</code></td>
<td>Delete a group.</td>
</tr>
<tr>
<td><code>grep</code></td>
<td>Catch lines with given text.</td>
</tr>
<tr>
<td><code>test</code></td>
<td>Test file for read, write or execute permissions.</td>
</tr>
<tr>
<td><code>if</code></td>
<td>If condition is true, then part is executed. else and <code>elif</code> are supported. <code>fi</code> is the end of <code>if</code>.</td>
</tr>
<tr>
<td><code>while</code></td>
<td>Run the loop so long as given condition is true.</td>
</tr>
<tr>
<td><code>for</code></td>
<td>Run given loop with stated arguments.</td>
</tr>
<tr>
<td><code>tree</code></td>
<td>Display tree structure of files and directories.</td>
</tr>
<tr>
<td><code>c++</code></td>
<td>Run C++ language compiler.</td>
</tr>
<tr>
<td><code>export</code></td>
<td>Place the variable, value pair in the shell environment.</td>
</tr>
<tr>
<td><code>clear</code></td>
<td>Clear contents of the screen.</td>
</tr>
<tr>
<td><code>ps</code></td>
<td>Display list of running processes.</td>
</tr>
<tr>
<td><code>kill</code></td>
<td>Kill/terminate process with given process ID.</td>
</tr>
</tbody>
</table>
Special characters in Linux shell

1 # What follows ’#’ character is comment.
2 * The wild card. Matches any number of letters.
3 ? Match any single character.
4 > Send output to a new file. Delete contents if file already exists.
5 >> Append the output of program to given file.
6 | Send output of the left side program to the input of the right side program.
7 $? Exit code of previous process. 0 denotes success.
8 & Run process to the left of & in the background.
9 - Denotes standard input (keyboard).
10 ~ Home directory.
11 [[]] Test condition.
12 ! Negation of condition.
13 && Run right side program only if the left side program succeeds.
14 || Run right side program only if the left side program fails.
Introduction to the various applications in office

► Microsoft office has a collection of tools for carrying out various productive jobs like preparation of document, accounting, mailing, presentation, database management, preparation of banners, visiting cards, etc.
► The packages in Microsoft office and their purposes are as follows:

<table>
<thead>
<tr>
<th>Sl. No.</th>
<th>Name of tool</th>
<th>Description /purpose</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Word</td>
<td>Helps preparation of documents.</td>
</tr>
<tr>
<td>2</td>
<td>Excel</td>
<td>Preparation of spreadsheets.</td>
</tr>
<tr>
<td>3</td>
<td>Powerpoint</td>
<td>Preparation of presentations.</td>
</tr>
<tr>
<td>4</td>
<td>Access</td>
<td>Creation and maintenance of databases.</td>
</tr>
<tr>
<td>5</td>
<td>Publisher</td>
<td>Tool for creating page based publications. Useful for creation of reports, banners, ID cards, etc.</td>
</tr>
<tr>
<td>6</td>
<td>Onenote</td>
<td>The program for creating and sharing notes.</td>
</tr>
<tr>
<td>7</td>
<td>Outlook</td>
<td>Email client. It fetches emails from several servers. It can also send emails.</td>
</tr>
</tbody>
</table>
Features of MS Word

- MS Word may be used for preparation of letters, memos, books, reports, theses, brochures and visiting cards.
- MS Word supports the paradigm of "WYSWYG" - which stands for What You See, What You Get. It means the hard copy will be similar to what is seen on screen.
- MS Word provides template documents for creating several types of publications. You may choose a template, fill required details to get a professional looking publication.
- MS Office supports a large number of images called clip arts.
- MS Word can take list from Excel or Access and create mail merged document addressed to several persons individually.
- MS Word checks spelling (red underline below spelling errors) and Grammar (green underline below grammatic mistakes).
- MS Word can handle tables, images and lists.
- MS Word supports water marks behind main text of the document, as in the case of certificates.
Office button in MS Word

- The circular button located at top left corner of MS Word window is the office button. In recent versions, office button has been renamed to File ((Alt + F)).
- Office button contains the following menu items (Fig.111):
  1) **Save:** Saves file (Ctrl+S or Alt+F+S).
  2) **Open:** Open a file (Ctrl+O or Alt+F+O).
  3) **Close:** Close current file (Alt+F+C).
  4) **Info:** Show permissions, author name, version details, pages, lines, words, duration of editing, etc. pertaining to current file (Alt+F+I).
  5) **Recent:** Show recently opened files (Alt+F+R).
  6) **New:** Create a new document (Ctrl+N or Alt+F+N). Templates may be chosen to provide a skeleton for the document.
  7) **Print:** Print the current document (Ctrl+P or Alt+F+P). Printer, paper size, finishing details, etc. can be controlled.
Office button in MS Word

Figure: Office menu in MS Word
Office button in MS Word

8) **Save & Send:**  Save current document and send it through email, save it on the web, share it to the blog, (Alt+F+D).

9) **Help:**  Help regarding MS Word (Alt+F+H or F1).

10) **Options:**  Options help to control several features of MS Word (Alt+F+T). Choosing **Advanced — > Print** and removing the tick mark in front of "Scale content for A4 or 8.5’x11’ paper sizes is important after installing windows. Otherwise all pages will be scaled to letter size paper instead of A4 size paper. General, display, proofing, save, language, advanced, etc. are common headings displayed under Options.

11) **Exit:** Close all documents and exit MS Word (Alt+F+X).
Toolbars in MS Word

Toolbars in MS Word are organized under the following menus:

(a) Home (Alt + H)
(b) Insert (Alt + N)
(c) Page Layout (Alt + P)
(d) References (Alt + S)
(e) Mailing (Alt + M)
(f) Review (Alt + R)
(g) View (Alt + W)

On pressing each menu, the toolbar related to that menu appears.

The toolbar is organized into suitable groups with a heading shown at the bottom of the toolbar.

Pressing the square shaped button at the bottom of each item in the toolbar opens a detailed menu related to that toolbar.
Fig. 114 shows the items contained in the Home menu of MS Word.
Home menu in MS Word

- Home menu contains many of the most essential items required for formatting a document (Fig.114), as detailed below:

(a) Clipboard (Alt + H + FO) - cut (Ctrl + X or Alt + H + X), copy (Ctrl + C or Alt + H + C), paste (Ctrl + V or Alt + H + V) & format painter (Alt + H + FP).

(b) Font style (Alt + H + FN) - bold (Ctrl + B or Alt + H + 1), italic (Ctrl + I or Alt + H + 2), underline (Ctrl + U or Alt + H + 3), strikethrough (Alt + H + 4), subscript (Ctrl + Plus or Alt + H + 5), superscript (Ctrl + Shift + Plus or Alt + H + 6), font name (Alt + H + FF), font size (Alt + H + FS), fill colour (Alt + H + I), font colour (Alt + H + FC).

(c) Paragraph formatting (Alt + H + PG) - bullets (Alt + H + U) & numbering (Alt + H + N), multilevel list (Alt + H + M), paragraph alignment (left (Ctrl + L or Alt + H + AL), right (Ctrl + R or Alt + H + AR), centre (Ctrl + E or Alt + H + AC) & justified (Ctrl + J or Alt + H + AJ)), line spacing (Alt + H + K), borders (Alt + H + B), fill color (Alt + H + H), decrease indent (Alt + H + AO), increase indent (Alt + H + AI).
Fig. 116 shows the items contained in the Insert menu of MS Word.

Figure: Insert menu in MS Word
Insert menu in MS Word

- Insert menu \((Alt + N)\) contains items insertion of items like pages, tables and images, as detailed below (Fig.116):
  
  (a) Page insertion - cover page \((Alt + N + V)\), blank page \((Alt + N + NP)\) & page break \((Alt + N + B)\).
  
  (b) Table insertion \((Alt + N + T)\) - simple table, table by rows and columns \((Alt + N + T + I)\), draw table \((Alt + N + D)\), convert text to table \((Alt + N + T + V)\), Excel spreadsheet \((Alt + N + T + X)\) & quick table \((Alt + N + T + T)\).
  
  (c) Illustrations - pictures \((Alt + N + P)\), clip art \((Alt + N + F)\), shapes \((Alt + N + SH)\) [line, rectangle, circle, arrows, flow chart, etc.], chart \((Alt + N + C)\), smart art \((Alt + N + M)\), screenshot \((Alt + N + SC)\).
  
  (d) Links - hyperlink \((Alt + N + I)\), bookmark \((Alt + N + K)\), cross reference \((Alt + N + RF)\).
  
  (e) Header & Footer - header \((Alt + N + H)\), footer \((Alt + N + O)\), page number \((Alt + N + NU)\).
  
  (f) Text - text box \((Alt + N + X)\), quick parts \((Alt + N + Q)\), word art \((Alt + N + I)\), drop cap \((Alt + N + RC)\), signature \((Alt + N + G)\), date & time \((Alt + N + D)\), object \((Alt + N + J)\).
Page Layout menu in MS Word

Fig. 118 shows the items contained in Page Layout menu in MS Word.
Page Layout menu in MS Word

Page Layout ($Alt + P$) menu (Fig.118) contains several options related to page size and layout, as detailed below:

(a) Theme - Theme ($Alt + P + TH$), Colors ($Alt + P + TC$), Fonts ($Alt + P + TF$), effects ($Alt + P + TE$).

(b) Page Setup ($Alt + P + SP$) - margins ($Alt + P + M$), orientation ($Alt + P + O$), size ($Alt + P + SZ$), columns ($Alt + P + J$ or ($Alt + P + J + C$)), break ($Alt + P + B$), line number ($Alt + P + LN$) & hyphenation ($Alt + P + H$).

(c) Page background - water mark ($Alt + P + PW$), page color ($Alt + P + PC$) & page border ($Alt + P + PB$).

(d) Paragraph ($Alt + P + PG$) - indent left ($Alt + P + IL$), indent right ($Alt + P + IR$) & spacing before ($Alt + P + SB$) and space after ($Alt + P + SA$).

(e) Arrange object - position ($Alt + P + PO$), text wrap ($Alt + P + TW$), bring forward ($Alt + P + AF$), selection pane ($Alt + P + AE$), select para ($Alt + P + AP$), align ($Alt + P + AA$), group ($Alt + P + G$) & rotate ($Alt + P + AY$)).
Fig. 120 shows the items contained in References menu in MS Word.
References menu in MS Word

References (Alt + S) menu (Fig.120) contains several options related to cross referencing of tables, images and citations, as detailed below:

(a) Table of Contents - table of contents (Alt + S + T), add text (Alt + S + A), update table (Alt + S + U).
(b) Foot notes (Alt+S+Q) - insert footnote (Alt + S + F), insert endnote (Alt + S + E), next footnote (Alt + S + O) & show notes (Alt + S + H)
(c) Citaion & Bibliography - insert citation (Alt + S + C), manage sources (Alt + S + M), style (Alt + S + L), bibliography (Alt + S + B).
(d) Captions - insert caption (Alt + S + P), insert table of figures (Alt + S + G), update table (Alt + S + V), cross reference (Alt + S + RF).
(e) Index - mark entry (Alt + S + N), insert index (Alt + S + X), update index (Alt + S + D).
(f) Table of authorities - mark citation (Alt + S + I), insert table of authorities (Alt + S + RT), update table (Alt + S + RU).
Mailings menu in MS Word

Fig. 122 shows the items contained in Mailings menu in MS Word.
Mailings menu in MS Word

Mailings \((Alt + M)\) menu (Fig.??) is the source of the famous mail merge function in MS Word. Mail merge functions may be visualized as a high level fill in the blanks, which can produce individualized messages from a general template. It has the following options:

(a) Create - envelopes \((Alt + M + E)\), labels \((Alt + M + L)\).

(b) Start Mail Merge - start mail merge \((Alt + M + S)\), select recipient \((Alt + M + R)\) - type new list \((Alt + M + R + N)\), use existing list \((Alt + M + R + E)\), select from outlook contacts \((Alt + M + R + O)\) & edit recipient list \((Alt + M + D)\).

(c) Write & Insert Fields - highlight merge fields \((Alt + M + H)\), address book \((Alt + M + A)\), greeting line \((Alt + M + G)\), insert merge field \((Alt + M + I)\), rules \((Alt + M + U)\), match fields \((Alt + M + T)\), update labels \((Alt + M + B)\).

(d) Preview Results - preview results \((Alt + M + P)\), first record \((Alt + M + Q)\), previous record \((Alt + M + M)\), record number \((Alt + M + W)\), next record \((Alt + M + X)\), last record \((Alt + M + V)\).

(e) Finish & Merge - finish & merge \((Alt + M + F)\), merge to new document, merge & print.
Fig. 124 shows the items contained in Review menu in MS Word.
Review menu in MS Word

- Review ($Alt + R$) menu (Fig.124) helps to check spelling, grammar and document statistics. It contains the following options:

(a) Proofing - spelling & grammar ($Alt + R + S$), research ($Alt + R + R$), thesaurus ($Alt + R + E$), word count ($Alt + R + W$).

(b) Languages - translate ($Alt + R + L$), language ($Alt + R + U$).

(c) Comments - new comment ($Alt + R + C$), delete ($Alt + R + D$), previous record ($Alt + R + V$), next ($Alt + R + N$).

(d) Tracking - track changes ($Alt + R + G$), final: show markup ($Alt + R + TD$), show markup ($Alt + R + TM$), reviewing pane ($Alt + R + TP$).

(e) Changes - accept ($Alt + R + A$), reject ($Alt + R + J$), previous ($Alt + R + F$), next ($Alt + R + H$).

(f) Compare - compare ($Alt + R + M$).

(g) Protect - block authors ($Alt + R + PB$), restrict editing ($Alt + R + PE$).
Fig. 126 shows the items contained in View menu in MS Word.

Figure: View menu in MS Word
Review menu in MS Word

- View (Alt + W) menu (Fig.126) helps to customize the appearance of document:

  (b) Show - ruler (Alt + W + R), gridlines (Alt + W + G), navigation pane (Alt + W + K).
  (c) Zoom - zoom (Alt + W + Q), 100 (Alt + W + J), two pages (Alt + W + 1), (Alt + W + 2), page width (Alt + W + L).
  (d) Window - new window (Alt + W + n), arrange all (Alt + W + A), split (Alt + W + S), view side by side (Alt + W + B), synchronous scrolling (Alt + W + YS), reset window position (Alt + W + T), switch windows (Alt + W + W).
  (e) Macros - Macros (Alt + W + M)
Creating, saving and formatting documents using M.S. Word

► When MS Word is opened without any argument, it displays a blank document.

► MS Word provides the following online templates (available only over an Internet connection) for creating new document: (i) agenda, (ii) award certificate, (iii) business cards, (iv) resumes, (v) budget, (vi) flier, (vii) brochure, (viii) visiting cards, (ix) calendars, (x) reports/ books, etc.

► After opening a document, it is necessary to set paper size, paper orientation (landscape or portrait) and margins on all four sides, before entering text. These settings can be accessed from PageLayout→Page Setup (Alt + P + SP) menu.

► Line spacing should be set through PageLayout→Paragraph (Alt + P + PG) menu.
Creating, saving and formatting documents using M.S. Word

- Text alignment can be set to center (Ctrl+E), left (Ctrl+L), right (Ctrl+R) or justified (Ctrl+J).
- Font face/name (Alt+H+FF), font size (Alt+H+FS), font colour (Alt+H+FC) and background colour (Alt+H+I) may be set to appropriate values for given document.
- Tables, figures and equations may be assigned caption using References-¿Insert caption (Alt+S+P). This will help MS Word to create list of tables, list of figures and list of equations automatically.
- To insert book title, chapter title, heading1, heading2, normal text, sue appropriate icons available under Home—→ Styles menu (Alt + H + L). Using this menu will help in the insertion of automatic table of contents.
Creating, saving and formatting documents using M.S. Word

▶ While typing references, use References—> Insert Citation (Alt + S + C). This will help in the insertion of automatic bibliography.

▶ To mark the words to be automatically indexed, use References—> Mark Entry (Alt + S + N). This will help in automatic insertion of index of words at the end of a document.

▶ Use Insert menu to insert table, picture, shapes, flow charts, headers, footers, page numbers, word art, drop cap, equation or symbol.

▶ To save a document, use File—> Save (Ctrl + S or Alt + F + S).

▶ To save the document in a new name, use File—> SaveAs menu (Alt + F + A).
Inserting objects in MS Word

- The most common objects used in MS Word are: (i) table, (ii) picture, (iii) geometric shapes, (iv) clip arts, (v) equations, (vi) lists.

- Table can be inserted from Insert $\rightarrow$ Table menu ($Alt + N + T$) in MS Word. Table caption is placed above the table. Use References $\rightarrow$ Insert Caption ($Alt + S + N$) to insert table caption.

- Pictures can be inserted from Insert $\rightarrow$ Picture ($Alt + N + P$) in MS Word. Picture caption is placed below the picture. Use References $\rightarrow$ Insert Caption ($Alt + S + N$) to insert table caption.

- Geometric shapes like line, circle, rectangle, text box, clip art, word art, flow chart symbols, etc. can be inserted from Insert menu.

- Equation may be inserted using Insert $\rightarrow$ Equation ($Alt + N + E$) menu. Equation numbers should be inserted using References $\rightarrow$ Insert Caption ($Alt + S + P$), to help automatic generation of the list of equations.
Inserting objects in MS Word

▶ To insert predefined art works, choose\n\textit{Insert}—\textit{ClipArt (Alt + N + F)} menu. This permits several simple artworks to be inserted in a document.

▶ Word art provides attractive size and shape for text headings. To insert word art, click \textit{Insert}—\textit{Word Art (Alt + N + RC)} menu.

▶ To insert a drop cap (First letter having height of several lines), use \textit{Insert}—\textit{Drop Cap (Alt + N + RC)} menu.

▶ Inserting a list is very simple in MS Word. Type a number or letter enclosed in parantheses [like (1)] or succeeded by a right paranthesis [like 1)]. This will induce MS Word to create a new list. Use the options available under \textit{Home—Paragraph} to customize the number format, letter format or bullet used for the list. Although MS Word automatically inserts successive numbers for list, specific values may be set by right clicking the unwanted number and choosing \textit{Numbering—Set Numbering Value} and typing required number in the number field.
Inserting macros in MS Word

- Macros help to create custom commands in MS Word, which will help us complete repeated works with ease. Imagine macro as a pet dog, which can take care of repeated works, once the initial training is complete.
- Macros may be assigned keystrokes or buttons.
- Initially, word does not show macros menu. Choose File → Word Options (Alt + F + T) menu, click Trust Center in the left side pane, click Trust Center Settings and click Enable all macros (not recommended, potentially dangerous code can run).
- To record a new macro (e.g. to type Government ITI for Women, Pondicherry, whenever Alt+W is pressed), open View menu, click Macros, choose Record Macro (Alt+W+M+R).
- Choose whether you create a button (left) or a keyboard shortcut.
- Choose whether the macro should be available to all documents or the present document only.
Inserting macros in MS Word

- Type a description of what the macro does and press OK. This starts the recording of macro. Mouse is disabled during macro recording. Hence, use keyboard to control the document.
- Simply carry out the work and allow the macro to learn what you do.
- When your work is complete, choose View -> Macro -> Stop Recording (Alt + W + M + R).
- Now, you can press the macro button placed at the title bar or type required keystroke to invoke the macro and get your work done.
Performing mail merge in MS Word

- Mail merge helps to make general purpose document targeting several persons to look as if the document was prepared for each individual separately, giving a feeling of trust and affinity.

- Prepare a document with blank spaces where individualized items like name, address, gender, age, etc. are to appear.

- Prepare a list of using MS Excel or MS Access, with suitable column names. The list could even be prepared using notepad, sufficient that rows are separated by newline and columns are separated by TAB.

- After completing the document, open Mailings → SelectRecepients → UseExistingList (Alt + M + R + E). Choose the MS Excel, MS Access or notepad text document containing the personal details. For MS Excel or MS Access name list, select work book name or table name (as appropriate) containing the list.
Performing mail merge in MS Word

▶ Now, choose *Mailings*—*InsertMergeField* (*Alt* + *M* + *I*) and choose the appropriate column name to be filled in each blank space.

▶ Choose *Mailings*—*PreviewResults* (*Alt* + *M* + *P*) to view the mail merged results.

▶ Mail merge results for each record may be viewed by accessing *Mailing*—*PreviewResults* tool bar and changing the record number.

▶ A new word document containing all mail merge results can be created using *Mailings*—*EditIndividualDocuments* (*Alt* + *F* + *E*). This document may be saved under a different name. Record range may be chosen for finishing the mail merge to new document.

▶ The mail merge results may be printed using *Mailings*—*PrintDocuments* (*Alt* + *F* + *P*). Record range may be chosen for finishing the mail merge to printer.

▶ The mail merge results may be sent through email to email ID’s specified in the document (if included) using *Mailings*—*SendEMailsMessages* (*Alt* + *F* + *S*). For this option to work, each row should have the email ID of the recepient.
Creating and using templates in MS Word

▶ Template in MS Word may be visualized as a standard mould using which several objects may be cast.

▶ After creating a document which is so well formatted that it is fit to serve as the standard for other documents, choose *File*— > *Save As*. In the save as dialog, click the triangular button to the right of *Save as type* and choose *Word Template*.

▶ A word template has *.dotx* extension, instead of the usual extension of *.docx* for normal word documents.

▶ When a Word template is opened, edited changes can be saved in a new word document with *.docx* extension.

▶ Templates are published magazines and journals to help the authors typeset their content according to the style specified in the template and suitable for their magazine or journal.
Page setup and printing documents using Word

- The first work on creating a document is page setup and the last work is to print or email that document.
- Page setup can be accessed using Page Layout → Page Setup (Alt + P + SP) menu.
- Page setup brings a dialog containing 3 panels, viz., Margins, Paper & Layout.
- Margins panel in page setup dialog helps to specify left margin, right margin, top margin and bottom margin. In addition to the margins, gutter margin (for binding) and gutter position (left or top) may also be specified.
- Margins panel in page setup dialog permits choosing paper orientation (portrait [width is less than height] or landscape [width is larger than height]), margin arrangement for multiple pages, preview of margin setup and applicability of the new page setup.
- Paper panel in page setup dialog permits selection of paper size (A4, letter, legal, etc.) and paper source.
- Layout panel of page setup dialog helps to choose whether section starts on new page, header and footer placement and vertical alignment of text and objects on page.
Page setup and printing documents using Word

➤ Printing a document is possible by choosing File— > Print (Ctrl + P) in the menu.

➤ The name of printer (which has already been installed), number of copies, page ranges to be printed, type of printing to be adopted for multiple copies (collated - divide by set, uncollated - take given number of copies in each page before proceeding to print the next page)

➤ Print dialog also permits access to printer properties, which may control print resolution, colour mode (in case of colour printer), finishing of pages, quality of print, etc.

➤ The print dialog also permits scaling of pages to suit available paper size.

➤ Pressing the print button sends the document to the printer and produces hard copy of the document.
Introduction to Excel features and Data Types. Cell referencing. Use of functions of various categories, linking Sheets. Introduction to various functions in all categories of Excel. Concepts of Sorting, Filtering and Validating Data. Analyzing data using charts, data tables, pivot tables, goal seek and scenarios. Introduction to Reporting.
Introduction to features of Excel

- Excel works on the basis of cells, one cell being the intersection of a column and a row.
- Columns (vertically aligned dividers) have the alphabet names (A, B, C, ..., Z, AA, AB, ..., AZ, BA, ...).
- Rows have numeric identifier (1, 2, 3, ...).
- Cells are addressed by combination of column name - row number, e.g. A1 for the first cell, B6 for the cell at second column, sixth row.
- Excel has a large collection of functions (entered in a cell after typing = sign), which are helpful in data analysis and computations.
- Excel can sort and arrange data in easily readable format.
- Excel can draw charts (like pie, bar, column, scatter, etc.) to help visualize data entered in cells.
- The latest version of Excel can have maximum of 10,48,576 rows and 16,384 columns. The maximum number of rows and columns may vary from version to version.
Introduction to features of Excel

- MS Excel can work with other applications like MS Word and MS Access.
- MS Excel can be used for storage and manipulation of small amount of data which may not qualify to occupy a database.
- MS Excel supports recording repeated actions and calling the same action sequences with the help of macros.
- MS Excel supports full fledged programming using Visual Basic for Applications (VBA).
- Each excel file is called a Workbook. Each workbook can have several sheets.
- By default, sheets in MS Excel are Sheet1, Sheet2, etc. The sheets can be renamed or copied by right clicking on sheet name.
- MS Excel files have default extension of `.xlsx`.
- Macro enabled excel files have the extension of `.xlsm`.
- A cell in MS Excel can reference data in the same sheet, other sheet in the same workbook or a sheet in another workbook.
Data types in Excel

- Following types of data are available in MS Excel:

1) *General* - Can be number, text, date, time or any other type.
2) *Number* - number permits control of decimal places and grouping of digits.
3) *Currency* - Currency format permits control of decimal places, digit grouping and prefixing of currency symbol.
4) *Accounting* - Permits control of number of digits and prefixing of currency symbol.
5) *Date* - Permits selection of date format from several available formats. The default date format used in India is DD/MM/YYYY.
6) *Time* - Permits selection time format.
7) *Percentage* - Displays a fraction (between 0 and 1) as a percentage. Decimal places of the percentage can be controlled.
Data types in Excel

8) *Fraction* - Permits display of decimal fraction into common fraction or vulgar fraction.

9) *Scientific* - Displays numbers in exponential notation.

10) *Text* - Displays given data as text.

11) *Special* - Special type is useful for tracking list and database values.

12) *Custom* - Number format may be customized using # (space or digit. 0 - zero or digit). Any text enclosed in double quotes is displayed as without any changes.
Cell referencing

- When the name of cell (like B5) is referenced in a formula, it can be done in 3 different ways, as detailed below:
  - Relative referencing - dynamic row & column change mode
  - Semi-relative referencing - dynamic row & static column mode or static row and dynamic column mode
  - Absolute referencing - static row & static column mode

- **Relative referencing**: In this mode, copying the formula to a new cell (e.g., add 4 to columns & 3 to rows) causes the cell reference to change relative to the new column (by adding the same 4 to columns & 3 to rows to the reference made in the formula).

- **Semi-relative referencing**: In this mode, either the row or column references are static, denoted by a $ symbol preceding the row number or column name.

- **Absolute referencing**: In this mode, both column name and row number are static and are preceded by a $ symbol. When the formula is copied from one cell to another, the cell references do not change.
Examples of cell referencing systems

a) **Relative referencing:** The formula \( = D3 + E3 \) is entered in cell F3. On copying the formula to cell K4, the copied formula becomes \( = I4 + J4 \), which references cells in relation to the cell containing the formula.

b) **Semi-relative referencing:** The formula \( = $D3 + $E3 \) is entered in cell F3. On copying the formula to cell K4, the copied formula becomes \( = $D4 + $E4 \), which references rows in relation to the cell containing the formula, but freezes any changes to the column name.

c) **Semi-Relative referencing:** The formula \( = D$3 + E$3 \) is entered in cell F3. On copying the formula to cell K4, the copied formula becomes \( = I3 + J3 \), which references columns in relation to the cell containing the formula, but freezes any changes to the row number.

d) **Absolute referencing:** The formula \( = $D$3 + $E$3 \) is entered in cell F3. On copying the formula to cell K4, the copied formula becomes \( = $D$3 + $E$3 \). Absolute system freezes all cell references.
Use of functions of various categories

▶ **Cube functions**: These functions look up and analyze data from a multi-dimensional database stored in a spreadsheet.

▶ **Database functions**: These functions help to access databases from Excel.

▶ **Date and Time functions**: These functions display and manipulate date and time values.

▶ **Engineering functions**: Converts number from one base to another, supports complex numbers, helps bit shifting and provides Bessel function.

▶ **Financial functions**: These functions support financial accounting in Excel.

▶ **Information functions**: These functions support determination of the properties of data (whether blank, number, text, etc.) contained in a cell.
Use of functions of various categories

▶ Logical functions: These are comparison functions which help carry out Boolean logic on data.

▶ Lookup and reference functions: These functions help to fund cell references using search, lookup, etc.

▶ Math & Trigonometry functions: These function help to manipulate numbers and determine trigonometric values.

▶ Statistical functions: These functions help to calculate statistical quantities like average, mode, median, standard deviation, etc.

▶ Text functions: These functions help to search, concatenate and manipulate text strings.
## DATE functions

<table>
<thead>
<tr>
<th></th>
<th>Function</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>DATE</td>
<td>Takes the arguments YYYY, MM, DD as input and returns a date.</td>
</tr>
<tr>
<td>2</td>
<td>DATEDIF</td>
<td>Calculates difference between given dates in years or months or days. Takes the start date, end date and the unit (“Y” for years, “M” for months and “D” for days.</td>
</tr>
<tr>
<td>3</td>
<td>DATEVALUE</td>
<td>Parses a text string and calculates date.</td>
</tr>
<tr>
<td>4</td>
<td>DAY</td>
<td>Returns day of month.</td>
</tr>
<tr>
<td>5</td>
<td>DAYS</td>
<td>Returns the number of days between two dates.</td>
</tr>
<tr>
<td>6</td>
<td>DAYS360</td>
<td>Calculates the number of days between two dates based on a 360-day year</td>
</tr>
<tr>
<td>7</td>
<td>EDATE</td>
<td>Returns the date which occurs particular number of months before or after the given date. Takes date as first argument, number of months as the second argument.</td>
</tr>
</tbody>
</table>
### DATE functions

<table>
<thead>
<tr>
<th></th>
<th></th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>8</td>
<td>EOMONTH</td>
<td>Returns the date last day of month given a start date and number of months. Takes date as first argument, number of months as the second argument.</td>
</tr>
<tr>
<td>9</td>
<td>HOUR</td>
<td>Converts a serial number to an hour.</td>
</tr>
<tr>
<td>10</td>
<td>ISOWEEKNUM</td>
<td>Returns the number of the ISO week number of the year for a given date.</td>
</tr>
<tr>
<td>11</td>
<td>MINUTE</td>
<td>Converts a serial number to a minute.</td>
</tr>
<tr>
<td>12</td>
<td>MONTH</td>
<td>Converts a serial number to a month.</td>
</tr>
<tr>
<td>13</td>
<td>NETWORKDAYS</td>
<td>Returns the number of whole workdays between two dates.</td>
</tr>
<tr>
<td>14</td>
<td>NETWORKDAYS.INTL</td>
<td>Returns the number of whole workdays between two dates using parameters to indicate which and how many days are weekend days.</td>
</tr>
<tr>
<td>15</td>
<td>NOW</td>
<td>Returns the serial number of the current date and time.</td>
</tr>
<tr>
<td>16</td>
<td>SECOND</td>
<td>Converts a serial number to a second.</td>
</tr>
<tr>
<td>17</td>
<td>TIME</td>
<td>Returns the serial number of a particular time.</td>
</tr>
</tbody>
</table>
### DATE functions

<table>
<thead>
<tr>
<th></th>
<th>Function</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>18</td>
<td>TIMEVALUE</td>
<td>Converts a time in the form of text to a serial number.</td>
</tr>
<tr>
<td>19</td>
<td>TODAY</td>
<td>Returns the serial number of today’s date.</td>
</tr>
<tr>
<td>20</td>
<td>WEEKDAY</td>
<td>Converts a serial number to a day of the week.</td>
</tr>
<tr>
<td>21</td>
<td>WEEKNUM</td>
<td>Converts a serial number to a number representing where the week falls numerically with a year.</td>
</tr>
<tr>
<td>22</td>
<td>WORKDAY</td>
<td>Returns the serial number of the date before or after a specified number of workdays.</td>
</tr>
<tr>
<td>23</td>
<td>WORKDAY. INTL</td>
<td>Returns the serial number of the date before or after a specified number of workdays using parameters to indicate which and how many days are weekend days.</td>
</tr>
<tr>
<td>24</td>
<td>YEAR</td>
<td>Converts a serial number to a year.</td>
</tr>
<tr>
<td>25</td>
<td>YEARFRAC</td>
<td>Returns the year fraction representing the number of whole days between start_date and end_date.</td>
</tr>
</tbody>
</table>
# Engineering functions

<table>
<thead>
<tr>
<th></th>
<th>Function</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>BIN2DEC</td>
<td>Converts binary number to decimal number.</td>
</tr>
<tr>
<td>2</td>
<td>BIN2HEX</td>
<td>Converts binary number to hexadecimal number.</td>
</tr>
<tr>
<td>3</td>
<td>BIN2OCT</td>
<td>Converts binary number to Octal number.</td>
</tr>
<tr>
<td>4</td>
<td>BITAND</td>
<td>Returns bitwise and for given numbers.</td>
</tr>
<tr>
<td>5</td>
<td>BITLSHIFT</td>
<td>Bitwise left shift.</td>
</tr>
<tr>
<td>6</td>
<td>BITOR</td>
<td>Bitwise OR for given numbers.</td>
</tr>
<tr>
<td>7</td>
<td>BITRSHIFT</td>
<td>Bitwise right shift of number.</td>
</tr>
<tr>
<td>8</td>
<td>BITXOR</td>
<td>Bitwise XOR of given numbers.</td>
</tr>
<tr>
<td>9</td>
<td>CONVERT</td>
<td>Converts given value from one system of units to another (e.g. “m” to “ft”).</td>
</tr>
<tr>
<td>10</td>
<td>DEC2BIN</td>
<td>Converts decimal number to binary number.</td>
</tr>
<tr>
<td>11</td>
<td>DEC2HEX</td>
<td>Converts decimal number to hexadecimal number.</td>
</tr>
<tr>
<td>12</td>
<td>DEC2OCT</td>
<td>Converts decimal number to Octal number.</td>
</tr>
<tr>
<td>13</td>
<td>DELTA</td>
<td>Tests whether given values are equal.</td>
</tr>
<tr>
<td>14</td>
<td>HEX2BIN</td>
<td>Converts hexadecimal number to binary number.</td>
</tr>
</tbody>
</table>
# Engineering functions

<table>
<thead>
<tr>
<th></th>
<th>Function</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>15</td>
<td>HEX2DEC</td>
<td>Converts hexadecimal number to decimal number.</td>
</tr>
<tr>
<td>16</td>
<td>HEX2OCT</td>
<td>Converts hexadecimal number to octal number.</td>
</tr>
<tr>
<td>17</td>
<td>COMPLEX</td>
<td>Creates a complex number from real and imaginary parts.</td>
</tr>
<tr>
<td>18</td>
<td>IMABS</td>
<td>Displays the absolute value of complex function.</td>
</tr>
<tr>
<td>19</td>
<td>IMAGINARY</td>
<td>Returns imaginary part of complex number.</td>
</tr>
<tr>
<td>20</td>
<td>IMREAL</td>
<td>Returns real part of complex number.</td>
</tr>
<tr>
<td>21</td>
<td>IMREAL</td>
<td>Returns conjugate of a complex number.</td>
</tr>
<tr>
<td>22</td>
<td>OCT2BIN</td>
<td>Converts octal number to binary number.</td>
</tr>
<tr>
<td>23</td>
<td>OCT2DEC</td>
<td>Converts octal number to decimal number.</td>
</tr>
<tr>
<td>24</td>
<td>OCT2HEX</td>
<td>Converts octal number to hexadecimal number.</td>
</tr>
</tbody>
</table>
### Cell functions

<table>
<thead>
<tr>
<th></th>
<th>Function</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>ERROR.TYPE</td>
<td>Returns a numeric identifier corresponding to an error type.</td>
</tr>
<tr>
<td>2</td>
<td>INFO</td>
<td>Returns information about the current operating environment.</td>
</tr>
<tr>
<td>3</td>
<td>ISBLANK</td>
<td>Returns true if a cell is blank.</td>
</tr>
<tr>
<td>4</td>
<td>ISERR</td>
<td>Returns true if the cell contains an error (other than #NA).</td>
</tr>
<tr>
<td>5</td>
<td>ISEVEN</td>
<td>Returns true if the number is even.</td>
</tr>
<tr>
<td>6</td>
<td>ISODD</td>
<td>Returns true if the cell contains an odd number.</td>
</tr>
<tr>
<td>7</td>
<td>ISFORMULA</td>
<td>Returns true if the cell contains a formula.</td>
</tr>
</tbody>
</table>
### Cell functions

<table>
<thead>
<tr>
<th></th>
<th>Function</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>8</td>
<td>ISLOGICAL</td>
<td>Returns true if the cell contains a logical (true or false) value.</td>
</tr>
<tr>
<td>9</td>
<td>ISNA</td>
<td>Returns true if there is #NA error.</td>
</tr>
<tr>
<td>10</td>
<td>ISNONTEXT</td>
<td>Returns true if the cell contains anything other than text.</td>
</tr>
<tr>
<td>11</td>
<td>ISNUMBER</td>
<td>Returns true if the cell contains a number.</td>
</tr>
<tr>
<td>12</td>
<td>ISREF</td>
<td>Returns true if the cell contains a reference to another cell.</td>
</tr>
<tr>
<td>13</td>
<td>ISTEXT</td>
<td>Returns true if the cell contains text.</td>
</tr>
<tr>
<td>14</td>
<td>N</td>
<td>Converts given input to a number.</td>
</tr>
<tr>
<td>15</td>
<td>NA</td>
<td>Returns a number corresponding to the #NA error type.</td>
</tr>
<tr>
<td>16</td>
<td>TYPE</td>
<td>Returns a number corresponding to the data type of the cell.</td>
</tr>
</tbody>
</table>
### Logical functions

<table>
<thead>
<tr>
<th></th>
<th><strong>AND</strong></th>
<th>Returns true only if all given conditions are true.</th>
</tr>
</thead>
<tbody>
<tr>
<td>2</td>
<td><strong>OR</strong></td>
<td>Returns true if at least one of the given conditions is true.</td>
</tr>
<tr>
<td>3</td>
<td><strong>FALSE</strong></td>
<td>Returns FALSE logical value.</td>
</tr>
<tr>
<td>4</td>
<td><strong>TRUE</strong></td>
<td>Returns TRUE logical value.</td>
</tr>
<tr>
<td>5</td>
<td><strong>IF</strong></td>
<td>Contains 3 parts separated by comma. In case the condition given at first part is true, the second part is executed. Otherwise, the condition given at the third part is executed.</td>
</tr>
<tr>
<td></td>
<td>Function</td>
<td>Description</td>
</tr>
<tr>
<td>---</td>
<td>----------</td>
<td>-------------</td>
</tr>
<tr>
<td>1</td>
<td>ABS</td>
<td>Returns the absolute (positive) value of the function, whether the input number is positive or negative.</td>
</tr>
<tr>
<td>2</td>
<td>ASIN</td>
<td>Inverse of sine value. Returns angle in radian for given input value (Input should be between 0 and 1).</td>
</tr>
<tr>
<td>3</td>
<td>ACOS</td>
<td>Inverse of cosine value. Returns angle in radian for given input value (Input should be between 0 and 1).</td>
</tr>
<tr>
<td>4</td>
<td>ATAN</td>
<td>Inverse of tangent value. Returns angle in radian for given input value.</td>
</tr>
<tr>
<td>5</td>
<td>ACOT</td>
<td>Inverse of cot value. Returns angle in radian for given input value (Input should be between 0 and 1).</td>
</tr>
<tr>
<td>6</td>
<td>ATAN2</td>
<td>Inverse of tangent value from given X and Y coordinates. Returns angle in radian for given input value.</td>
</tr>
<tr>
<td>7</td>
<td>AGGREGATE</td>
<td>Returns aggregate value like sum, count, etc. from a database.</td>
</tr>
</tbody>
</table>
## Math functions

<table>
<thead>
<tr>
<th></th>
<th>Function</th>
<th>Description</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>8</td>
<td>ARABIC</td>
<td>Converts Roman numeral to Arabic numeral.</td>
<td></td>
</tr>
<tr>
<td>9</td>
<td>ASINH</td>
<td>Returns inverse of hyperbolic sin.</td>
<td></td>
</tr>
<tr>
<td>10</td>
<td>ATANH</td>
<td>Returns inverse of hyperbolic tangent.</td>
<td></td>
</tr>
<tr>
<td>11</td>
<td>CEILING</td>
<td>Returns an integer just above the given fractional number.</td>
<td>=CEIL(2.1) returns 3.</td>
</tr>
<tr>
<td>12</td>
<td>FLOOR</td>
<td>Returns an integer just below the given fractional number.</td>
<td>=FLOOR(2.99) returns 2.</td>
</tr>
<tr>
<td>13</td>
<td>ROUND</td>
<td>Rounds a number to given number of digits.</td>
<td>=ROUND(2.99,1) returns 3.0, =ROUND(2.629,2) returns 2.63, =ROUND(2.5,0) returns 3.0, =ROUND(23154.25,-2) returns 23200.</td>
</tr>
<tr>
<td>14</td>
<td>ROUNDDOWN</td>
<td>Rounds a number to given number of digits.</td>
<td>But it simply truncates the trailing digits, without considering whether the truncated digit is below 5 or not. e.g. =ROUNDDOWN(2.99,1) returns 2.9, =ROUNDDOWN(2.629,2) returns 2.62, =ROUNDDOWN(2.5,0) returns 2.0, =ROUNDDOWN(23154.25,-2) returns 23100.</td>
</tr>
</tbody>
</table>
## Math functions

<table>
<thead>
<tr>
<th>No.</th>
<th>Function</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>15</td>
<td>ROUNDUP</td>
<td>Rounds a number to given number of digits. But it simply adds one to the last digit, without considering whether the truncated digit is below 5 or not. e.g. =ROUNDUP(2.99,1) returns 3.0, =ROUNDUP(2.622,2) returns 2.63, =ROUNDUP(2.1,0) returns 3.0, =ROUNDUP(23124.25,-2) returns 23200.</td>
</tr>
<tr>
<td>16</td>
<td>COMBIN</td>
<td>Returns number of possible combinations for given number of objects ( nC_r ).</td>
</tr>
<tr>
<td>17</td>
<td>DEGREES</td>
<td>Returns degree value of angle for given angular value in radian.</td>
</tr>
<tr>
<td>18</td>
<td>EVEN</td>
<td>Returns the nearest even number just above the given number.</td>
</tr>
<tr>
<td>19</td>
<td>ODD</td>
<td>Returns the nearest odd number just above the given number.</td>
</tr>
<tr>
<td>20</td>
<td>EXP</td>
<td>Returns exponential value of a given number.</td>
</tr>
<tr>
<td></td>
<td>Function</td>
<td>Description</td>
</tr>
<tr>
<td>---</td>
<td>------------</td>
<td>-----------------------------------------------------------------------------</td>
</tr>
<tr>
<td>21</td>
<td>FACT</td>
<td>Returns factorial of given number.</td>
</tr>
<tr>
<td>22</td>
<td>FACTDOUBLE</td>
<td>Returns factorial of given number.</td>
</tr>
<tr>
<td>23</td>
<td>GCD</td>
<td>Returns greatest common divisor of the number.</td>
</tr>
<tr>
<td>24</td>
<td>INT</td>
<td>Returns integer value just below the given real number.</td>
</tr>
<tr>
<td>25</td>
<td>LCM</td>
<td>Returns least common multiple of given numbers.</td>
</tr>
<tr>
<td>26</td>
<td>LN</td>
<td>Returns natural logarithm of given number.</td>
</tr>
<tr>
<td>27</td>
<td>LOG</td>
<td>Returns common logarithm of given number.</td>
</tr>
<tr>
<td>28</td>
<td>LOG10</td>
<td>Returns logarithm of given number to the base 10.</td>
</tr>
<tr>
<td>29</td>
<td>MDETERM</td>
<td>Returns determinant of given matrix.</td>
</tr>
<tr>
<td>30</td>
<td>MINVERSE</td>
<td>Returns inverse of given matrix.</td>
</tr>
<tr>
<td>31</td>
<td>MMUL</td>
<td>Multiplication result of given matrices.</td>
</tr>
<tr>
<td>32</td>
<td>MOD</td>
<td>Returns modulo reminder of division.</td>
</tr>
<tr>
<td>33</td>
<td>MROUND</td>
<td>Returns nearest value rounded to the given multiple.</td>
</tr>
<tr>
<td>34</td>
<td>PI</td>
<td>Returns the value of PI (3.1415...).</td>
</tr>
<tr>
<td>35</td>
<td>POWER</td>
<td>Returns the given power of a number.</td>
</tr>
</tbody>
</table>
## Math functions

<table>
<thead>
<tr>
<th></th>
<th>Function</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>36</td>
<td>QUOTIENT</td>
<td>Returns quotient of division.</td>
</tr>
<tr>
<td>37</td>
<td>RADIANS</td>
<td>Returns radians for given degree angle.</td>
</tr>
<tr>
<td>38</td>
<td>RAND</td>
<td>Returns a random number.</td>
</tr>
<tr>
<td>39</td>
<td>RANDBETWEEN</td>
<td>Returns a random number between given input numbers.</td>
</tr>
<tr>
<td>40</td>
<td>ROMAN</td>
<td>Returns Roman numeral for given Arabic number.</td>
</tr>
<tr>
<td>41</td>
<td>SIGN</td>
<td>Returns sign ± + or -.</td>
</tr>
<tr>
<td>42</td>
<td>SQRT</td>
<td>Returns square root of the given number (only positive numbers are permitted in argument).</td>
</tr>
<tr>
<td>43</td>
<td>SUBTOTAL</td>
<td>Returns subtotal of given numbers.</td>
</tr>
<tr>
<td>44</td>
<td>SUM</td>
<td>Returns sum of given numbers.</td>
</tr>
<tr>
<td>45</td>
<td>SUMIF</td>
<td>Returns sum of given numbers if given condition is fulfilled.</td>
</tr>
<tr>
<td>46</td>
<td>SUMSQ</td>
<td>Returns sum of squares of given numbers.</td>
</tr>
<tr>
<td>47</td>
<td>TRUNC</td>
<td>Truncates given number to integer value.</td>
</tr>
<tr>
<td></td>
<td>Function</td>
<td>Description</td>
</tr>
<tr>
<td>---</td>
<td>----------</td>
<td>-------------</td>
</tr>
<tr>
<td>1</td>
<td>AVEDEV</td>
<td>Returns average of absolute/unsigned deviation of data from the mean.</td>
</tr>
<tr>
<td>2</td>
<td>AVERAGE</td>
<td>Returns average of given numbers.</td>
</tr>
<tr>
<td>3</td>
<td>AVERAGEA</td>
<td>Returns average of given numbers, text and logical values.</td>
</tr>
<tr>
<td>4</td>
<td>AVERAGEIFS</td>
<td>Returns average of given numbers which meet criteria specified.</td>
</tr>
<tr>
<td>5</td>
<td>CORREL</td>
<td>Returns coefficient of correlation between given data sets.</td>
</tr>
<tr>
<td>6</td>
<td>COUNT</td>
<td>Returns count of items in specified range.</td>
</tr>
<tr>
<td>7</td>
<td>COUNTIF</td>
<td>Counts the number of items in specified range, only if that item meets specified criterion.</td>
</tr>
<tr>
<td>8</td>
<td>COUNTIFS</td>
<td>Counts the number of items in specified range, only if that item meets several criteria specified after the first argument.</td>
</tr>
<tr>
<td>9</td>
<td>COUNTA</td>
<td>Counts the number of arguments provided to the function.</td>
</tr>
<tr>
<td>10</td>
<td>COUNTBLANK</td>
<td>Counts the number of blank cells in specified range.</td>
</tr>
<tr>
<td></td>
<td>Function</td>
<td>Description</td>
</tr>
<tr>
<td>---</td>
<td>----------</td>
<td>-------------</td>
</tr>
<tr>
<td>11</td>
<td>DEVSQ</td>
<td>Returns sum of squares of deviations.</td>
</tr>
<tr>
<td>12</td>
<td>FORECAST</td>
<td>Returns the most probable next value in a set of dependent and independent variables.</td>
</tr>
<tr>
<td>13</td>
<td>GEOMEAN</td>
<td>Returns geometric mean of given values.</td>
</tr>
<tr>
<td>14</td>
<td>GROWTH</td>
<td>Returns exponential forecast for a new X value based on given Y and X values.</td>
</tr>
<tr>
<td>15</td>
<td>LARGE</td>
<td>Returns rank based large value in a data set.</td>
</tr>
<tr>
<td>16</td>
<td>MAX</td>
<td>Returns highest numeric value.</td>
</tr>
<tr>
<td>17</td>
<td>MAXA</td>
<td>Returns highest value from the given numbers, text or logical values.</td>
</tr>
<tr>
<td>18</td>
<td>MEDIAN</td>
<td>Returns the median (the data that occurs at the middle) of given set of data.</td>
</tr>
<tr>
<td>19</td>
<td>MIN</td>
<td>Returns the least value of given numbers.</td>
</tr>
</tbody>
</table>
Statistical functions

<table>
<thead>
<tr>
<th></th>
<th></th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>20</td>
<td>MINA</td>
<td>Returns the least value of given numbers, text and logical values.</td>
</tr>
<tr>
<td>21</td>
<td>PERMUT</td>
<td>Returns permutation for given number of objects.</td>
</tr>
<tr>
<td>22</td>
<td>RANK</td>
<td>Returns rank for a given value in comparison to a list of values.</td>
</tr>
<tr>
<td>23</td>
<td>SMALL</td>
<td>Returns smallest number having given rank value.</td>
</tr>
<tr>
<td>24</td>
<td>STDEV</td>
<td>Returns standard deviation of given list of numbers.</td>
</tr>
</tbody>
</table>
# Text functions

<table>
<thead>
<tr>
<th></th>
<th>Function</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>CHAR</td>
<td>Returns character having the given code number under ASCII (American Standard Code for Information Interchange) system.</td>
</tr>
<tr>
<td>2</td>
<td>CODE</td>
<td>Returns numeric code of given character.</td>
</tr>
<tr>
<td>3</td>
<td>CONCATENATE</td>
<td>Combines multiple string values.</td>
</tr>
<tr>
<td>4</td>
<td>DOLLAR</td>
<td>Returns given number in currency format based on current locale.</td>
</tr>
<tr>
<td>5</td>
<td>EXACT</td>
<td>Compares given text values.</td>
</tr>
<tr>
<td>6</td>
<td>FIND</td>
<td>Returns the index/location count of the occurrence of first string within the second (larger) string.</td>
</tr>
<tr>
<td>7</td>
<td>FORMAT</td>
<td>Formats a number with fixed number of decimal places.</td>
</tr>
<tr>
<td>8</td>
<td>LEFT</td>
<td>Returns leftmost character from a string.</td>
</tr>
<tr>
<td>9</td>
<td>RIGHT</td>
<td>Returns rightmost character from a string.</td>
</tr>
<tr>
<td>10</td>
<td>LEN</td>
<td>Returns length of a string.</td>
</tr>
</tbody>
</table>
### Statistical functions

<p>| | | |</p>
<table>
<thead>
<tr>
<th></th>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>11</strong></td>
<td><strong>LOWER</strong></td>
<td>Converts given string to lowercase letters.</td>
</tr>
<tr>
<td><strong>12</strong></td>
<td><strong>UPPER</strong></td>
<td>Converts given string to uppercase letters.</td>
</tr>
<tr>
<td><strong>13</strong></td>
<td><strong>PROPER</strong></td>
<td>Capitalizes the first letter of each word in given string.</td>
</tr>
<tr>
<td><strong>14</strong></td>
<td><strong>REPLACE</strong></td>
<td>Takes a string for first argument. Takes start location for replacement, number of characters to be replaced as second and third arguments. The given range is replaced using the string given in the fourth argument.</td>
</tr>
<tr>
<td><strong>15</strong></td>
<td><strong>REPT</strong></td>
<td>Repeat the text given in first argument for number of times specified in second argument.</td>
</tr>
<tr>
<td><strong>16</strong></td>
<td><strong>SEARCH</strong></td>
<td>Returns the index/location of occurrence of first text within second text (case insensitive).</td>
</tr>
</tbody>
</table>
# Text functions

<table>
<thead>
<tr>
<th></th>
<th></th>
<th>Takes target string, search string and replacement string as arguments. Replaces second string with the third string in the first string.</th>
</tr>
</thead>
<tbody>
<tr>
<td>17</td>
<td>SUBSTITUTE</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>Returns text value. Does not return anything for number and logical values.</td>
</tr>
<tr>
<td>18</td>
<td>T</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>Formats the number given in the first argument according to format specified in the second argument.</td>
</tr>
<tr>
<td>19</td>
<td>TEXT</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>Removes spaces from the beginning and end of given string.</td>
</tr>
<tr>
<td>20</td>
<td>TRIM</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>Converts text to number.</td>
</tr>
<tr>
<td>21</td>
<td>VALUE</td>
<td></td>
</tr>
</tbody>
</table>
Sorting in MS Excel

- To sort data, select all the cells containing the data to be sorted.
- Avoid the most common mistakes of selecting the just the single column containing the values to be sorted and omitting some columns which you might consider unnecessary of inclusion. Such an error may result in separation of data from its proper row members.
- Click Data -> Sort. In the dialog that opens, keep or remove the tick mark against the field "My data contains headers".
- The sort options contain 3 columns. First, select the column using which data needs to be sorted. In case the data contains headers, the header name is displayed. Otherwise, column name in alphabets (A,B,C,...) is displayed.
- In the second criterion, choose either values, cell color or cell icon.
- In the third criterion, choose smallest to largest or largest to smallest for number. Choose A to Z or Z to A for text data.
- Press sort button to sort the data.
Filtering of data in MS Excel

- For filtering data, the first row should contain headers.
- Select all the data including headers.
- Choose *Data* → *Filter*. A triangular filter marker appears to the right of each column in the first row of data.
- Clicking the triangular marker of any column permits sorting in ascending or descending order, sorting by color, search for specific values, applying several filter conditions for numbers (like equals, does not equal, greater than, less than, less than or equal to, between, top 10, above average, below average, custom filter) and text (like equals, does not equal, begins with, ends with, contains, does not contain, custom filter).
- Filter helps to select data based on convenient criterion.
Validation of data in MS Excel

- Select the cells (or column or row) in which data validation is required.
- Choose *Data* > *Data Validation* from the menu. Select Data Validation.
- The data validation dialog appears.
- Select the data type from *Allow* criterion.
- Select the data criterion (between, not between, equal to, not equal to, greater than, less than, greater than or equal to, less than or equal to).
- Enter the values for validation.
- If you wish to display an error message for wrong input, click Input Message tab and enter the title and content of error message.
- Press OK to apply the condition.
- To indicate error in data by circle, choose *Data* > *Data Validation* > *Circle invalid data*. 
Analyzing data using charts in MS Excel

- MS Excel supports column, line, pie, area, scatter and other chart types like stock, surface, doughnut, bubble and radar.
- To display a chart like column, line, pie or bar, type X-Axis title in the one column and Y-Axis title in the next column.
- Enter X-Axis values and Y-Axis values in the selected columns.
- Select the data (including title).
- Choose Insert menu. Click the type of chart like column, line, pie, bar or scatter.
- The chart is inserted by Excel.
- Edit display parameters if necessary.
Data tables in MS Excel

- Using data table, Excel can be made to calculate the results for a row, a column or an array.
- If you wish to create a column based data table, fill the input values on the left. Calculate the result for the first row.
- Select the entire table, choose Data → What If Analysis → Data Table.
- Choose first column in the input box (leave the row value blank).
- Excel will fill up the remaining blank cells.
- Similarly, you can create a row based data table. You need to create a row based input, calculate the result in the first column of the next row. Choose first cell of the row in row input (leave the column value blank) during creation of data table.
Data tables in MS Excel

- If you wish to create a matrix using data table, enter input values in 2 cells, calculate the result value in a new cell.
- Create a row of inputs to the right of the result cell.
- Create a column of inputs below the result cell.
- Select the new matrix. Leave the row and column input cells unselected.
- Choose What Data→If Analysis→Data Table.
- In the input box, select the cells for row and column input.
- When OK button is pressed, Excel fills all the cells of the matrix based on your formula.
Pivot table in MS Excel

- Pivot table (and pivot chart) provide a means for summarizing data presented in a table.
- Choose the table based on which pivot table needs to be created.
- Choose Insert → Pivot → Pivot Table.
- MS Excel inserts a summary table in a new worksheet.
Goal seek in MS Excel

- Suppose you have a formula in a cell.
- If you wish to know the input for which the formula will yield a desired result, goal seek will help you.
- Click the cell containing the formula. Choose Data—›What If Analysis—›Goal Seek.
- In the first cell of the dialog, enter desired result.
- In the second cell, enter the address of the cell containing wrong input, which needs to be adjusted to produce the desired new result.
- Press seek button and see the suggested new input value.
- Press OK to accept the modified input and cancel to discard the changes.
Scenarios in MS Excel

 Scenario helps to save different sets of input values and compare the results of different scenario later on.

 To create a scenario, create a set of input values and calculate the result.

 Choose Data—>What If Analysis—>Scenario. Enter a title.

 Choose cells for which different sets of input values are to be tested. Use control to select more than one cell.

 Save the scenario with an optional comment.

 Repeat the same steps to create more such scenarios. Save different input values for each scenario.

 You can choose any of the scenario at a later time to see the results.
Image editing, Introduction to the properties and editing of images. Introduction to Open Office.
Types of image

Images belong to the following 2 categories:

(i) **Raster image**: Raster images have pixel as their basic unit. The most common types of raster image are JPEG (Joint Photographic Experts Group), PNG (Picture Natural Group), TIFF (Tagged Image File Format), GIF (Graphics Interchange Format), PNG (Portable Network Graphics), etc.

(ii) **Vector image**: Vector images store details of geometrical shapes and the parameters needed to redraw those shapes. The most common formats used to store vector images are SVG (Scalable Vector Graphics), CGM (Computer Graphics Metafile), etc.
Basics of digital images

- Digital images comprise of pixels arranged in rectangular grids.
- Each pixel is a dot in an image.
- In monitor display, the colour of each pixel is determined based on RGB (Red-Green-Blue) system, HSL (Hue-Saturation-Lightness) system or HSV (Hue Saturation Value) system.
- For printing, CMYK (Cyan-Magenta-Yellow-black) colour system is adopted.
- The transparency value of a pixel is represented by Alpha value (usually 0 to 255).
- The spacing of pixels per inch on an image display is measured using PPI (Pixels Per Inch).
- The spacing of pixels per inch on an image display is measured using PPI (Pixels Per Inch).
Image editing

- Digital images are generated through digital photography, digital image editing software, scanning of painted images, etc.

- Image editing is necessitated due to:
  1. Photograph having low exposure.
  2. Photos which require touchup.
  3. Merging or splitting of digital images.
  4. Resizing or scaling of digital images.
  5. Adjusting brightness of digital images.
  6. Adjusting contrast of digital images.
  7. Creating printable albums and layouts.

- Software packages like GIMP, Adobe Photoshop, CorelDraw, etc. help in editing digital images.
Basic adjustments to an image

- **Brightness and contrast** values of an image may be adjusted using Image ➔ Adjustments ➔ Brightness/Contrast menu. Brightness and contrast sliders may be used to make changes to the image.

- **Brightness, contrast and threshold** values of an image may be adjusted using Image ➔ Adjustments ➔ Levels menu. The histogram values may be adjusted to make changes to the image.

- **Brightness and contrast** values of an image may be adjusted using Image ➔ Adjustments ➔ Curves menu. The straight line on the histogram values may be adjusted up or down to make changes to the image.
Tools available in Adobe Photoshop

- **Rectangular Marquee Tool (M)** in Adobe Photoshop permits selection of rectangular/elliptical areas. It also permits single or single column marquee selection.

- **Lasso Tool (L)** in Adobe Photoshop permits selection of irregular areas (like face from an image, hand from an image, etc). Lasso tool provides Polygonal lasso and magnetic lasso options. Whereas Lasso selection is made between a click and release of mouse button, polygonal lasso permits placing several points along a selection path. Magnetic lasso tool places suitable points along the path of selection when the mouse is simply dragged through a boundary.

- **Quick selection tool (W)** in Adobe Photoshop creates a polygonal selection using the selection points. It provides Magic wand option, which is very popular to select areas having a specific colour similarity.

- **Crop tool (C)** in Adobe Photoshop retains selected area and discards unwanted portions.
Tools available in Adobe Photoshop

- **Eye dropper tool (I)** in Adobe Photoshop selects colour from specific point.

- **Spot healing brush tool (J)** in Adobe Photoshop take sample from one image (or area) and blend it with another image. Spot healing tools can be configured to work as Healing brush tool, Patch tool, Content-aware move tool or Red eye tool.

- **Brush tool (B)** in Adobe Photoshop helps to draw using selected colour. Brush tool can be configured to work like Pencil tool, Color replacement tool or Mixer brush tool.

- **Clone stamp tool (S)** in Adobe Photoshop takes a sample from one area (Alt+Mouse click) and applies the same in a new place (Mouse click). This tool has the option for Pattern stamp tool.
Tools available in Adobe Photoshop

- **History brush tool (S)** in Adobe Photoshop stores previous sample and mixes the same with the newly painted layer.

- **Eraser tool (E)** in Adobe Photoshop removes contents of the current layer and exposes the background layer. It has the options for Background eraser tool and Magic eraser tool.

- **Gradient tool (G)** in Adobe Photoshop fills selected area with a colour gradient, which gradually changes from one colour to another. It has the option for Bucket fill tool.

- **Blur tool** in Adobe Photoshop reduces the visibility/ clarity of selected portion of an image. It has the options for Sharpen tool and Smudge tool.

- **Dodge tool (O)** in Adobe Photoshop reduces the sharpness of an image. It has the option of Burn tool to increase sharpness and Sponge tool to saturate or de-saturate colours.
Tools available in Adobe Photoshop

- **Pen tool (O)** in Adobe Photoshop helps to draw a shape and convert the shape to selection, path or vector mask or define a custom shape by right clicking the closed shape.

- **Horizontal type tool (T)** in Adobe Photoshop helps to type text elements. It has options for vertical type, horizontal type mask and vertical type mask.

- **Path selection tool (A)** in Adobe Photoshop selects elements bounded by a path. It has option for direct selection tool.

- **Rectangle tool (U)** in Adobe Photoshop draws a rectangle. It has options for rounded rectangle, ellipse, polygon and line.

- **Hand tool (H)** in Adobe Photoshop drags a drawing (PAN). It has option for Rotate tool.

- **Zoom tool (Z)** in Adobe Photoshop enlarges or shrinks the visible area of image on the screen. It does not affect the size of the original image.
Simple tasks in image editing

▶ **Create maxi size photos:** Choose File → New (Ctrl+N). Set the width to 12 inches and 8 inches and resolution to 200 pixels per inch. If Ruler is not visible, press Ctrl+R (View → Rulers). Drag the left line and top line of ruler to mid width and mid height respectively. Drag and drop 4 photos on 4 parts of the image. Adjust the size and other effects of photos as you desire.

▶ **Create Passport size photo layout:** Choose File → New (Ctrl+N). Set the width to 12 inches and 8 inches and resolution to 200 pixels per inch. Open the photo which should be set to passport size. Use polygonal lasso (or any other tool) to select the required portion of image. Select All (Ctrl+A) and Copy (Ctrl+C) the photo. Create new image, paste the photo. Choose Image → Image Size and enter 3cm x 5cm size (for passport size photo). Press Ctrl+A, Ctrl+C to copy. Choose Original blank image (12in x 8in). Paste multiple times, drag the photo and arrange the photos without wastage of space.
Simple tasks in image editing

▶ **Create a photo album:** Choose File→New (Ctrl+N). Set width=16 inch and height=10 inch (width and height may change based on requirements). Set resolution to 300 dots per inch. Drag the required photo and place it on the page. Resize the photo and place it in a convenient position. Drag more photos and organize them. Use blur tool or smudge tool or sponge tool to blend the overlapping portions. Save the file. Export it to JPG format. Create many such pages (one page per file).

▶ **Create a banner:** Choose File→New (Ctrl+N). Set width=72 inch and height=48 inch (width and height may change based on requirements). Set resolution to 300 dots per inch. Draw a rectangle and choose suitable fill color for background. Place text objects are required locations. Copy and paste (or drag and drop) images. Resize the images to required size. Save the document and export it to JPG type.
Create a video using photos: Choose File—>New (Ctrl+N). At the bottom of Adobe Photoshop window, video timeline appears. Click the triangular button next to video frame icon and choose Add media. Select all the photos to be used in the video. Increase or decrease the duration for each photo (default 5 seconds) by dragging the boundary of the photo. Audio track can be added using the audio icon. Choose File—>Export—>Render video. Enter file name and press Render button. The video is exported to MP4 format.
Introduction to Open Office

▶ *OpenOffice.org* was an open source and free software released in the year 2000, as the successor to the proprietary office suite called Star Office.

▶ OpenOffice contains a word processor (Writer), spreadsheet (Calc), Presentation creator (Impress), drawing editor (Draw), formula editor (Math) and a database tool (Base).

▶ File→>New menu in OpenOffice permits creation of all types of document supported by OpenOffice.

▶ OpenOffice displays File, Edit, View, Insert, Format, Tools, Window and Help menus by default. Some extra menus might appear to suit the needs of specific programs.

▶ OpenOffice features similar to those offered by MS Office.

▶ OpenOffice can open and edit most of the MS Office documents.

▶ The native file formats of OpenOffice.org are presented in Table 6.
<table>
<thead>
<tr>
<th>No.</th>
<th>File extension</th>
<th>Purpose</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>.odt</td>
<td>ODF Text.</td>
</tr>
<tr>
<td>2</td>
<td>.ott</td>
<td>ODF Template Text.</td>
</tr>
<tr>
<td>3</td>
<td>.odm</td>
<td>ODF Master Document.</td>
</tr>
<tr>
<td>4</td>
<td>.ods</td>
<td>ODF Spreadsheet.</td>
</tr>
<tr>
<td>5</td>
<td>.ots</td>
<td>ODF Spreadsheet Template.</td>
</tr>
<tr>
<td>6</td>
<td>.odg</td>
<td>ODF Drawing.</td>
</tr>
<tr>
<td>7</td>
<td>.otg</td>
<td>ODF Template Drawing.</td>
</tr>
<tr>
<td>8</td>
<td>.odp</td>
<td>ODF Presentation.</td>
</tr>
<tr>
<td>9</td>
<td>.otp</td>
<td>ODF Template Presentation.</td>
</tr>
<tr>
<td>10</td>
<td>.odf</td>
<td>ODF Formula.</td>
</tr>
<tr>
<td>11</td>
<td>.odb</td>
<td>ODF Database.</td>
</tr>
</tbody>
</table>
Syllabus

*Introduction to PowerPoint and its advantages. Creating Slide Shows. Fine tuning the presentation and good presentation techniques.*
Microsoft Powerpoint, (command name `powerpnt`), is a tool for creating presentations.

Powerpoint is included as a part of Microsoft Office.

Powerpoint files have extension of `.pptx`. Files created using Powerpoint in earlier versions of MS Office (up to 2003) had extension of `.ppt`.

Powerpoint helps to create slide by slide presentations.

Powerpoint is helpful for making classroom presentations, business proposals and progress reports.
Menu structure of Power Point

Powerpoint has the following menu structure:

(i) **File/ office:**

(a) Save (Alt+F+S, Ctrl+S)
(b) Save As (Alt+F+A)
(c) Open (Alt+F+O, Ctrl+O)
(d) Close (Alt+F+C)
(e) Info (Alt+F+I)
(f) Recent (Alt+F+R)
(g) New (Alt+F+N, Ctrl+N)
(h) Print (Alt+F+P, Ctrl+P)
(i) Save & Send (Alt+F+D)
(j) Help (Alt+F+H)
(k) Options (Alt+F+T)
(l) Exit (Alt+F+X).
Home menu

(ii) **Home:**

(a) **Clipboard (Alt+H+FO),** Paste (Alt+H+V, Ctrl+V), Cut (Alt+H+X, Ctrl+X), Copy (Alt+H+C, Ctrl+C), Format Painter (Alt+H+FP).

(b) **Slides,** Insert (Alt+H+I, Ctrl+M), Layout (Alt+H+L), Reset (Alt+H+Q), Selection (Alt+H+T).

(c) **Font (Alt+H+FN),** Font Face (Alt+H+FF), Font Size (Alt+H+FS), Font Grow (Alt+H+FG), Font Decrease (Alt+H+FK), Bold (Alt+H+1, Ctrl+B), Italic (Alt+H+1, Ctrl+I), Underline (Alt+H+U, Ctrl+U), Text Shadow (Alt+H+5), Strikethrough (Alt+H+4), Character spacing (Alt+H+6), Change case (Alt+H+7, Shift+F3), Font Color (Alt+H+FC).

(d) **Paragraph (Alt+H+PG),** Bullets (Alt+H+U), Numbering (Alt+H+N), Decrease list level (Alt+H+AO), Increase list level (Alt+H+AI), Align left (Alt+H+AL, Ctrl+L), Align Right (Alt+H+AR, Ctrl+R), Justify (Alt+H+AJ, Ctrl+J), Columns (Alt+H+J), Line Spacing (Alt+H+K), Text direction (Alt+H+AX), Align text (Alt+H+AT), Convert to Smart Art Graphic (Alt+H+M).
(e) **Drawing (Alt+H+O)**, Shapes (Alt+H+SH), Arrange (Alt+H+G), Shape Quick Styles (Alt+H+SS), Shape Fill (Alt+H+SF), Shape Outline (Alt+H+SO), Shape Effects (Alt+H+SE).

(f) **Editing**, Find (Alt+F+FD, Ctrl+F), Replace (Alt+H+R, Ctrl+H), Select (Alt+H+SL), Select All (Ctrl+A).
Insert & Design menu

(iii) Insert:

(a) **Table (Alt+N+T).**
(b) **Images,** Picture (Alt+N+P), Clip Art (Alt+N+F), Screenshot (Alt+N+SC), Photo (Alt+N+A).
(c) **Illustrations,** Picture (Alt+N+SH), Smart Art (Alt+N+M), Chart (Alt+N+C).
(d) **Links,** Hyperlink (Alt+N+U), Action (Alt+N+K).
(e) **Text,** Text Box (Alt+N+X), Header & Footer (Alt+N+H), Word Art (Alt+N+W), Date & Time (Alt+N+D), Slide Number (Alt+N+SN), Object (Alt+N+J).
(f) **Symbols,** Equation (Alt+N+E), Symbol (Alt+N+U)

(iv) Design:

(a) **Page Setup,** Page Setup (Alt+G+S), Slide Orientation (Alt+G+O).
(b) **Themes,** Colours (Alt+G+TC), Fonts (Alt+G+TF), Effects (Alt+G+TE), More (Alt+G+H).
(c) **Background (Alt+G+G),** Background Styles (Alt+G+B), Slide Background (Alt+G+M)
Transitions & Animations menu

(v) Transitions
   (a) Preview  Preview (Alt+K+P, F5)
   (b) Transition, More (Alt+K+T), Effect Options (Alt+K+O).
   (c) Timing, Sound (Alt+K+U), Duration (Alt+K+E), Apply to all (Alt+K+L), On mouse click (Alt+K+M), After (Alt+K+F).

(vi) Animations
   (a) Preview, Preview (Alt+A+P), Animations (Alt+A+M), Shapes (Alt+A+S), Effect Options (Alt+A+O).
   (b) Advance Animation, Add Animation (Alt+A+AA), Animation Pane (Alt+A+C), Trigger (Alt+A+AT), Animation Painter (Alt+A+AP).
   (c) Timing, Start (Alt+A+T), Duration (Alt+A+DU), Delay (Alt+A+DE), Move Earlier (Alt+A+E), Move Later (Alt+A+L).
(vii) **Slide Show**

(a) **Start Slide Show** From Beginning (Alt+S+B, F5), From Current (Alt+S+C, Shift+F5), Broadcast Slide Show (Alt+S+D), Slide show (Alt+A+M).

(b) **Setup** Setup Slide Show (Alt+S+S), Hide Slide (Alt+S+H), Rehearse Timings (Alt+S+T), Record Slide Show (Alt+S+N), Play Narrations (Alt+S+P), Use Timings (Alt+S+U), Show Media Controls (Alt+S+W).

(c) **Monitors** Resolution (Alt+S+R), Show On (Alt+S+O), Use Presenter View (Alt+S+V).

(viii) **Review**

(a) **Proofing**, Spelling (Alt+R+S), Research (Alt+R+R), Thesaurus (Alt+R+E).

(b) **Language**, Translate (Alt+R+2), Language (Alt+R+U).

(c) **Comments**, Show Markup (Alt+R+M), View Comment (Alt+R+C), Edit Comment (Alt+R+T), Delete (Alt+R+D), Edit Comment (Alt+R+T), Previous (Alt+R+V), Next (Alt+R+N).

(d) **Compare**, Compare (Alt+R+G), Accept (Alt+R+A), Reject (Alt+R+T), Previous (Alt+R+F), Next (Alt+R+H), Preview Pane (Alt+R+I), End Review (Alt+R+W).
Creating Slide Shows

- Slide show can be created by choosing File → New from menu or by pressing Ctrl+N/ Alt+F+N.
- Presentation starts with a single slide.
- Choose suitable design for the presentation from Design menu. Different slide colours and designs are available.
- Choose Headers and Footers from Insert → Text → Header & Footer (Alt+N+H). Set appropriate values for header and footer.
- First slide requires name of presentation, author name and other details related to the presentation.
- Insert new slide by choosing Home → Slides → Insert or pressing Ctrl+M/ Alt+H+I.
- The new slide has a caption. Fill appropriate caption.
- Text can be typed in the contents area. If table or image is required, moving the mouse on the contents permits changing the display area to table or image.
- Content layout in a slide can be changed by from design menu.
Creating Slide Shows

- Slide transition effects may be controlled using Transitions— >Transition menu.

- Animation for slide transition may be applied from Animations— >Preview— >Animations or Animations— >Preview— >Shapes or Animations— >Preview— >Effect Options.

- Slide show can be started from current slide (Shift+F5) or from the beginning (F5). To stop presentation, press Esc key.

- Mistakes in spelling are underlined in red colour. Spelling mistakes can be corrected by choosing Review— >Proofing— >Spelling from menu or by pressing Alt+R+S.
Fine tuning a presentation

▶ Presentation may be made to change slides at specified interval automatically using Animations—Timing—Duration.

▶ Specified tone may be permitted to play at the time of each slide transition using Transitions—Timing—Sound.

▶ Audio may be recorded for each slide using Slide Show—Setup—Record Narration (Alt+S+N). This audio plays when the slide is presented. Recording may be verified using Slide Show—Setup—Play Narration (Alt+S+P).

▶ Search may be carried out using Home—Editing—Find (Ctrl+F/ Alt+H+FD).

▶ Replace may be carried out using Home—Editing—Replace (Ctrl+H/ Alt+H+R).
Good presentation techniques

▶ Choose contrasting background and foreground colours (light background and dark foreground OR dark background and light foreground).

▶ Choose mild animations for slide transition. Fast and repeating animations create irritation to the audience.

▶ Transition effects may be applied uniformly to all slides. Different transition effect for each slide might distract the attention of the audience.

▶ Text in each slide should be large enough for the audience to read without strain.

▶ In case of automated slide transition in presentation, the duration should be sufficient for even the slowest reader to read/ observe the slide.
Syllabus

Data

- Information collected for storage, reference and analysis purpose is called data.
- Data may be in the form of digital text or numbers.
- Data may be stored in paper format or in electronic storage.
- Datum is the singular form for the word data.
- Data related to financial transactions is used for accounting.
- Survey is a systematic method for data collection.
- Specialized software for storage, analysis and retrieval of data is called Database Management System (DBMS).
Information

- Details collected about a particular object is called information.
- While data can be a collection of unrelated details, information has some common theme.
- Information is always used in singular form.
- Storage and transmission of information is the main use of communication technology in the modern era.
- Digital information may be stored in hard drive, optical drive, SD card, pen drive, cloud storage or data centre.
Database

- The system for storage and retrieval of data in digital format is called database.

- Database can be stored in a single computer or in multiple computers.

- Database makes the storage and retrieval of data easy for the client.

- Databases are of the following types:
  - (i) Navigational or Hierarchical database - 1960-1970
  - (ii) Relational Database - Edgar Codd - 1970 - SQL (Structured Query Language)
  - (iii) Object Oriented Database Management System (OODBMS) - 1990
  - (iv) NoSQL - 2000 - Fast, unstructured, inconsistent - Mostly used by Social Media platforms.
  - (v) NewSQL - 2000 - Combination of NoSQL engine with SQL interface.
**Popular databases**

1. **Oracle**: Oracle is one of the most popular database software. Oracle is fully compliant with all the rules applicable for Relational Database Management System (RDBMS). Oracle is the platform preferred by many professional organizations.

2. **Microsoft SQL Server**: Microsoft SQL Server is fast growing platform for database management. It provides fast performance and is available for Windows, Linux and Mac operating systems. It provides easy integration with MS Excel and other software packages.

3. **IBM DB2**: IBM DB2 is a high performance database engine providing back end services for many business organizations and insurance companies. IBM was the leader in the field of Relational Database Management, since Edgar Codd, was an employee of IBM and DB2 was one of the first relational database systems.

4. **Teradata**: Teradata supports large scale databases and provides fast data analytics to help in business decision making.
Popular databases

5 **MySQL**: MySQL was developed by MySQL AB, bought by Sun Microsystems and bought again by Oracle. MySQL is an open source database engine. MySQL is the preferred database system for web based applications.

6 **PostgreSQL**: PostgreSQL is an enterprise grade RDBMS and OODBMS available under open source licensing.

7 **MongoDB**: MongoDB is a NOSQL database engine. MongoDB has the advantage of speed and flexibility and is used by social media platforms where speed and flexibility are more important than data integrity.

8 **SAP ASE**: SAP (formerly Sybase) Adaptive Server Enterprise (ASE) is a fast relational database system.

9 **Informix**: Informix is an object oriented database system and supports NoSQL features. It is owned by IBM.

10 **Microsoft Access**: Microsoft Access is suitable for desktop based database management. It provides facilities to create forms and reports.

11 **SQLite**: SQLite is a light weight database engine used for data storage in mobile operating systems like Android, iOS, etc.
Codd’s Rules for RDBMS

- **Rule 0 - Foundation rule**: A relational database system must be able to manage data entirely through relational rules.
- **Rule 1 - Information rule**: Data in a database should be held only in table.
- **Rule 2 - Guaranteed access rule**: Each and every datum should be accessible through a combination of table, key and column.
- **Rule 3 - Null value rule**: Absence of data should be represented through null value, irrespective of data type.
- **Rule 4 - Active online catalogue rule**: Table schema should also be stored in tables and should be accessible through SQL.
- **Rule 5 - Comprehensive data sublanguage rule**: Database should be accessed only through data sublanguage (SQL). No other mode of access is permitted.
- **Rule 6 - View updating rule**: All views theoretically updatable should be updatable by the system.
Codd’s Rules for RDBMS

▶ **Rule 7 - High level insert, update and delete rule:** The data sub-language should support insert, update and delete operations in addition to select option.

▶ **Rule 8 - Physical data independence:** The mode of physical storage media and structure of media should not affect the data sub-language.

▶ **Rule 9 - Logical data independence:** Any application accessing the data should be unaffected by the changes to schema used for data tables.

▶ **Rule 10 - Integrity independence:** Database must be independent of the application using the data.

▶ **Rule 11 - Distribution independence:** End user must not feel any difference between data stored in local media and data stored in several locations (over the network).

▶ **Rule 12 - Non-subversion rule:** Data must not be manipulated through any mode other than the data sub-language (SQL).
Key terms related to RDBMS

1 **RDBMS**: Relational Database Management System. It is compliant with Codd’s rules and is accessed through SQL.

2 **SQL**: Structured Query Language - the sub-language used to work with RDBMS.

3 **Database**: A collection of tables used to store data.

4 **Table**: A group of columns used to store data related to an individual entity.

5 **Column**: One subhead for storing data in a table (like name, mobile_number, email_id, etc.)

6 **Row or Record**: One set of information relating to an object which fills up all the columns with data values (including null value), like (’Amala’,’345345345’,’amala@xyz.com’).
Key terms related to RDBMS

7 **Row**: One set of information relating to an object which fills up all the columns with data values (including null value), like (’Amala’,’345345345’,’amala@xyz.com’).

8 **Data Type**: A column may have a data type. Common data types supported by MySQL are char, varchar, int, date, time, datetime, bigint, double, clob, blob. Different database servers support slightly different names for data types.

9 **Primary key**: The main column used for indexing and searching data is called primary key. Primary key does not support duplicate values.

10 **Foreign key**: The primary key of a different table used in another table for relational, searching and indexing purposes is called foreign key. Foreign key permits duplicate values.

11 **Constraints**: NOT NULL, AUTO_INCREMENT, UNIQUE, DEFAULT, PRIMARY KEY, FOREIGN KEY, INDEX etc. are some of the constraints used to fill columns with valid data.
Rules for designing good tables

1 Determine the purpose of the database.
2 Organize the information to be stored in the database.
3 Divide the information into suitable tables.
4 Define column values and primary key.
5 Define relationships between tables.
6 Apply rules of normalization (The objectives of normalization are to reduce data redundancy and to make sensible data dependencies or relations.):
   (i) 1NF or First Normal Form: Define column names and data types.
   (ii) 2NF or Second Normal Form: Remove repetition of data.
   (iii) 3NF or Third Normal Form: Define a primary key for each table.
   (iv) 4NF or Fourth Normal Form: Divide unrelated columns of table into separate tables.
   (v) 5NF or Fifth Normal Form: If columns in a table can be divided into separate tables connected by appropriate keys, the table should be further divided.
1 **Domain Integrity**: Specifying suitable constraints and setting values permitted and not permitted in a table is called domain integrity. For example, specifying that ID is a primary key and has auto_increment attributes is one way of specifying domain integrity.

2 **Entity integrity**: Every table should have a primary key.

3 **Referential integrity**: Value referred in a foreign key column should be present in some other table as a value in primary column.
Relationships in tables

1 **One to many relationship**: One primary key column of a table getting referred many times through foreign key value in another table (patient.ID and visit.PATIENT_ID columns in patient and visit tables).

2 **Many to many relationship**: The appearance of many keys of first table against many other keys of a second table is called many to many relationship (Many product IDs of product table appearing in several order IDs of order table is an example of many to many relationship).

3 **One to one relationship**: If one key value of first table appears only once in a second table, it is called one to one relationship (the relation between personal.AADHAR and contact.AADHAR is one to one and cannot have more than one relationship).
Queries and their uses

1 **DDL - Data Definition Language**: The commands used to create or alter databases and tables is called DDL. Typical DDL commands are:
   (i) create database ITI;
   (ii) create table TRAINEE (reg_no varchar(14) primary key, name varchar(50), dob date not null, mark int not null default 0, max_mark int not null default 1);
   (iii) alter table trainee add column percentage double default 0 after max_mark;
   (iv) drop table TRAINEE;
   (v) drop database ITI;

2 **DML - Data Manipulation language**: Helps to insert, update and delete data values.
   (i) insert into trainee values('001784000132','Mala','2002-03-19',460,500,92.00);
   (ii) update trainee set name='Malarvizhi' where reg_no='001784000132';
   (iii) delete from trainee where reg_no='001784000132';

3 **DQL - Data Query Language**: SQL commands used to select data from tables falls under the category of DQL.
   (i) select reg_no, name, dob from TRAINEE where name='Malarvizhi';
   (ii) select reg_no, name, dob from TRAINEE where reg_no='001784000132';
   (iii) select * from TRAINEE order by dob;
   (iv) select * from TRAINEE order by dob DESC;
   (v) select * from TRAINEE where name like 'Ma%'
   (vi) select * from TRAINEE where name like '%arvi%';
   (vii) select average(percentage) from TRAINEE;
   (viii) select average(percentage) from TRAINEE group by dob;
   (ix) select average(percentage) from TRAINEE group by dob order by percentage;
   (x) select average(percentage) from TRAINEE having dob > '2000-01-01' group by dob order by percentage;

4 **DCL - Data Control Language**: Used for database administration functions like creating user, changing password, granting rights, revoking rights, etc.
MS Access

- Microsoft Access is a program in MS Office for maintaining databases.
- MS Access is suitable for small and offline databases.
- MS Access permits easy creation of databases, tables, queries, forms and relations using visual tools.
- MS Access databases support Open Data Base Connectivity (ODBC) technology - which helps easy access to data from desktop and online clients.
Creating database using MS Access

- When MS Access opens, a dialog is displayed to choose an existing database or to create a new database.
- When asked
Creating database in MS Access

- Open MS Access, either by choosing Start—>All Apps—>Microsoft Office—>Access or by pressing Windows+R, entering "msaccess" followed by enter key.
- By default, MS Access displays the list of most recently used databases.
- To create a new database, choose Blank Database icon.
- Enter name of the new database in the box displayed at the lower right corner.
- Press create button to create the new database.
Data types supported by MS Access

- MS Access supports the following data types:
  
  (i) **Text**: for text up to 255 characters in length.
  
  (ii) **Memo**: for large amount of text.
  
  (iii) **Number**: Sizes supported by number are: Byte, Integer, Long Integer, Single, Double, Replication ID, Decimal.
  
  (iv) **Number**: Sizes supported by number are: Byte, Integer, Long Integer, Single, Double, Replication ID, Decimal.
  
  (v) **Date/Time**: This data type can store only date, only time or both date and time.
  
  (vi) **Currency**: Currency data type supports a symbol for currency name and number.
  
  (vii) **AutoNumber**: This data type permits automatic assignment of a unique ID number to the column values.
  
  (viii) **Yes/No**: Stores simple yes or no (true or false) values.
  
  (ix) **OLE Object**: Object Linking and Embedding (OLE) is the data type for inserting data created using other programs in MS Access table.
  
  (x) **Hyperlink**: This data type supports clickable links to web pages.
Creating tables in MS Access

- Table can be created using Create-¿Table (Alt+C+TN) in the MS Access menu.
- Table1 is the default name for new table. Right click on the table name, select Rename and enter a new name (say contacts). You could right click on top of the table name, choose Design View and enter a new name.
- Leave the first column with name of ID and Data Type of Autoincrement. This column is the primary key for contacts.
- In the second column, enter name_of_person and Text against Field Name and Data Type.
- In the third column, enter mobile and Number.
- Create a new table with columns {ID: AutoNumber, person_id: Number, email1: Text, email2: Text}. 
Creating relationships between tables in MS Access

- Relationship is the linking of primary key from one table to a corresponding foreign key in another table.
- Relationship allows splitting of data, removes unwanted repetition of information and reduces storage requirement.
- Choose Database Tools—>Relationships. In the result table list, select the tables which are to be related (contact and email).
- Identify the columns to be related (ID in contact and person_id in email) in both tables.
- Drag the column ID from contact and drop it on column person_id in email. A dialog appears to confirm the linking of columns. Press OK.
- Now the tables contact and email are related to each other through the columns ID and personal_id respectively.
Creating forms in MS Access

▶ To run a form, choose Form from Design menu or right click on Form name and choose Form view.
▶ Choose Create—>Form to create an input and editing form for the tables. This is the default form for tables.
▶ To insert a split form (Displays input fields on top and rows at the bottom), choose Create—>Split Form.
▶ To create a form displaying multiple rows of data, choose Create—>Multiple Items.
▶ To create a summary report like number of records, sum of column, etc., create Pivot chart. Drag and drop Summary fields and filter fields to customize the results.
▶ Create a customized form using different data values, choose Create—>Blank Form. Drag and drop the columns required inside the form from the related tables.
▶ To create a form using step by step addition of columns and applying several customizations to the themes, choose Create—>Form Wizard.
▶ To display a summary of results based on filter criteria, choose Create—>Pivot Table.
Creating reports in MS Access

► To run a report, choose Report from Design menu or right click on Report name and choose Report view.

► Choose Create ➔ Report to create a blank report. Double click the columns required to be included in the report.

► Choose Create ➔ Blank Report to get a blank report form which can be customized.

► Choose Create ➔ Report Wizard to create a report through a step by step process.
Creating queries in MS Access

- MS Access permits creation of SQL queries through visual inputs.
- Choose Create— >Query Wizard to create a query through a step by step process. It allows for simple query based on one table or multi-tab query or duplicate finder query or unmatched query.
- Choose Create— >Query Design to create a query using design mode.
- When the query title is right clicked, choices for SQL view, design view, etc. are available.
Macros in MS Access

- Repeated actions carried out the MS Access can be stored in Macros.

- Macros in MS Access can be recorded through View → Macros → Record Macro. The recording can be stopped through similar process using View → Macros → Stop recording.

- On pressing the pre-assigned keystroke or pressing the macro button, the macro begins to work.
Computer Networks

- The communication infrastructure meant for sharing of data between computers is called computer network.
- Connection between computers may be through cable, WiFi (Wireless Fidelity), bluetooth or any other method.
- Modem, repeater, hub, bridge, switch, firewall, etc. are the essential infrastructure to run a network.
- Each computer connected to a computer assumes a unique identifier called IP (Internet Protocol) Address (IP4 - 216.58.201.174, IP6 - 2001:0db8:85a3:0000:0000:8a2e:0370:7334).
- Domain name is converted to equivalent IP address using Domain Name Server (DNS).
- IP4 address is 32 bits (4 bytes) in length.
- Internet is controlled by the World Wide Web Consortium (W3C).
There are 3 classes of IP address, as detailed below:

(i) **Class - A network (Fig.49):** High order byte (right most 8 bits) of the network is reserved for network ID. The remaining 24 bits are used to set IP address of the host. This permits 126 networks and 16,777,214 hosts per network.

![Class A network diagram]

Figure: Address bit configuration: Class A network [55]
(ii) **Class - B network (Fig.50):** High order 2 bytes (right most 16 bits) of the network are reserved for network ID. The first and second bits of network ID are always 1 and 0. The remaining 14 bits are used to set network IDs (16,384 networks). The lower 2 bytes of the IP address are meant for host ID (16,534 hosts).

Figure: Address bit configuration: Class B network [55]
(iii) **Class - C network (Fig.51):** High order 3 bytes (right most 24 bits) of the network are reserved for network ID. The first, second and third bits of network ID are always 1, 1 and 0. The remaining 21 bits are used to set network IDs (2,097,152 networks). The lowest byte of the IP address is meant for host ID (254 hosts).

Figure: Address bit configuration: Class C network [55]
Necessity for computer networks

- Computer networks are necessary for email communications.
- Computer networks are necessary for sharing of printer and other hardware resources.
- Computer networks are necessary for the maintenance of cloud storage.
- Computer networks are necessary for core banking system.
Advantages of computer networks

- Computer networks help in communication of information through email.
- Computer networks help in sharing of information through Voice Over IP (VOIP), social media (Facebook, Twitter, Instagram, WhatsApp, Telegram, etc.).
- Computer networks help in the dissemination of information through the World Wide Web (WWW).
- Computer networks help the creation of web portals, which help to carry out business transactions.
- Computer networks help the storage and retrieval of information in cloud storage platforms, to help in the safe maintenance and easy access of information.
- Computer networks help in the sharing of printers and other shareable devices.
- Computer networks help in the maintenance of bank account transactions through core banking system.
- Computer networks help in the sharing of large files through File Transfer Protocol.
Client Server computing

- Client and server are two computers behaving like a customer and service person in a hotel desk.
- Both the client and the server have a unique IP address (to locate the computer on the network) and Port number (to identify the program which communicates over the network).
- The sets of \{IP_{client}, Port_{client}\} and \{IP_{server}, Port_{server}\} are called half associations.
- Taken together, the IP and port data of client and server (\{IP_{client}, Port_{client}\} and \{IP_{server}, Port_{server}\}) form a full association.
- On getting connected, the client places a request to the server to get some job done (like the customer placing an order to the service person in a hotel desk).
Client Server computing

- The server gets any additional data required for processing, completes the job and delivers the result to the client (like the service person in a hotel desk offering the food items ordered by the customer).
- The client side half association \( \{ IP_{client}, Port_{client} \} \) is called client socket.
- The server side half association \( \{ IP_{server}, Port_{server} \} \) is called server socket.
- As a real world example, www.google.com is a server and the user computer accessing it is a client.
- The server awaits the arrival of a client request, completes the request and keeps waiting for clients (called listening).
- The client and server might use Transmission Control Protocol (TCP) for error free transmission of sensitive data (like bank transactions, email, etc.).
- The client and server might use User Datagram Protocol (UDP) for fast communication with some errors (like video sharing, audio sharing) where small errors are permissible.
Peer to peer networking

- Peer to peer communication takes place between two computers connected on an equal status (unlike client and server).
- Peer to peer communication helps to share files and folders.
- Peer to peer communication helps in the easy sharing of printers and scanners.
- Peer to peer communication has the limitation of not permitting connection to any external network.
Proxy server, Firewall and Proxy Firewall

- **Proxy servers**: Proxy servers run as the intermediary between actual server and the client. The proxy server helps in content filtering and load balancing of web servers.

- **Firewall**: Firewall separates a small network from the Internet. It scrutinizes all incoming and outgoing data and prevents communication of harmful data.

- **Proxy Firewall**: Proxy Firewall is an improvement to the actual firewall and provides security at deeper levels (layer 7 of the 7 layer OSI model) of communication than the firewall. Proxy firewall separates a small network from the Internet. It scrutinizes all incoming and outgoing data and prevents communication of harmful data.
Network Topologies

Figure: Network topologies [56]
Network Topologies (Fig.52)[56]

(i) **Bus topology**: Bus topology provides a single linear network cable to which all other nodes are connected.

(ii) **Star topology**: Star topology provides single central node through which all other nodes communicate with each other.

(iii) **Ring topology**: Ring topology ends where it began, all computers/ nodes connected to the endless ring.

(iv) **Mesh topology or Fully connected topology**: Mesh topology or fully connected topology has direct connection between all computers connected to the network. It offers speed by it is costly.

(v) **Tree topology**: Tree topology allows each node of the network to divide/ diverge into 2 separate connections, each new node dividing till the end of network is reached.

(vi) **Hybrid topology**: Hybrid topology allows different portions of the network to adopt different topologies (like tree, mesh, ring, etc.), with each topology connected to the other.
Network types

(i) **PAN - Personal Area Network**: Tiny network running inside a few rooms of a building, typically created using Bluetooth technology, is called Personal Area Network (PAN).

(ii) **LAN - Local Area Network**: Small network running inside a building is called Local Area Network (LAN).

(iii) **CAN - Campus Area Network**: The network consisting of several LANs located inside the campus, typically inside a University or College, is called Campus Area Network (CAN).

(iv) **MAN - Metropolitan Area Network**: A network larger than a LAN, running across several buildings in a geographical area (or a small city) is called Metropolitan Area Network (MAN).

(v) **WAN - Wide Area Network**: The network spread over a large area, interconnecting several LANs and MANs is called Wide Area Network (WAN).
Networking hardware

(i) **Gateway**: Gateway converts speeds, protocols and speeds between heterogeneous networks.

(ii) **Router**: Router forwards data packets to other routers. Each router commands the traffic between different networks.

(iii) **Hub**: Hub transmits data between computers connected in a LAN. Hub simply receives a data packet and forwards the data to all other computers connected to the network, whether the data is addressed to a computer or not. Hub results in inefficient data transmission.

(iv) **Switch**: Switch is a device which transmits data received from one node to just those computers which are meant to receive the data. It results in efficient data transmission.

(v) **Bridge**: Bridge is a device which connects several networking segments.

(vi) **Repeater**: Repeater receives a signal which is weak and transmits the same at full energy to increase the range of the signal.

(vii) **MODEM**: MODEM stands for MODulation DEModulation - which converts analogue signal to digital signal and vice versa. MODEM converts digital information from computer to analogue signal over telephone line and vice versa.
Networking hardware

Figure: Networking hardware [57]
Networking cables

(i) **Unshielded Twisted Pair (UTP) Cable**: 4 pairs of cables twisted together and usually connected through RJ45 is called twisted pair. CAT 5e and CAT 6 cables are common twisted pair cables.

(ii) **Shielded Twisted Pair (STP) Cable**: When each cable of twisted pair is individually shielded using metal foil and the entire set of cables is collectively shielded, the cable is called shielded twisted pair. This type of cable is less susceptible to electromagnetic interferences.

(iii) **Coaxial Cable**: A copper core surrounded by plastic insulation and a metal hood is called coaxial cable. Provides fast data transmission and long range.

(iv) **Fiber Optic Cable**: Glass fibre core surrounded by plastic insulation and a metal core is called fire optic cable. It provides very high speed, very long range and very low loss of energy during transmission. Fibre optic cable is not affected by electromagnetic disturbances.
Networking cables

Figure: Unshielded and Shielded twisted pair [58]

Figure: Coaxial cable [59]

Figure: Coaxial cable [60]
**Wireless communication**

(i) **NFC - Near Field Communication**: It works between two mobile devices when gently touching each other. Used for payment at PoS and pairing of bluetooth devices.

(ii) **Bluetooth**: Bluetooth is a wireless communication technology with connection range of 40m to 400m under bluetooth version 4.

(iii) **WiFi - Wireless Fidelity**: WiFi is a technology for fast data transmission within a range of 100m. Mobile devices have to pair to a WiFi hotspot to enable data transmission.
## OSI 7 layer model

<table>
<thead>
<tr>
<th>Layer</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>7</td>
<td>Application Layer</td>
</tr>
<tr>
<td></td>
<td>✓ Message format, Human-Machine Interfaces</td>
</tr>
<tr>
<td>6</td>
<td>Presentation Layer</td>
</tr>
<tr>
<td></td>
<td>✓ Coding into 1s and 0s; encryption, compression</td>
</tr>
<tr>
<td>5</td>
<td>Session Layer</td>
</tr>
<tr>
<td></td>
<td>✓ Authentication, permissions, session restoration</td>
</tr>
<tr>
<td>4</td>
<td>Transport Layer</td>
</tr>
<tr>
<td></td>
<td>✓ End-to-end error control</td>
</tr>
<tr>
<td>3</td>
<td>Network Layer</td>
</tr>
<tr>
<td></td>
<td>✓ Network addressing; routing or switching</td>
</tr>
<tr>
<td>2</td>
<td>Data Link Layer</td>
</tr>
<tr>
<td></td>
<td>✓ Error detection, flow control on physical link</td>
</tr>
<tr>
<td>1</td>
<td>Physical Layer</td>
</tr>
<tr>
<td></td>
<td>✓ Bit stream: physical medium, method of representing bits</td>
</tr>
</tbody>
</table>

Figure: OSI 7 layer model [61]
Network protocols

- Protocol is a set of rules for transmission of data across the network and communication between client and server.

- **IP**: Internet Protocol (IP) is the procedure used for transmission of data by routing of data packets from one host to another. Each host connected to a network is assigned a unique ID called IP Address.

- **TCP/IP**: Transmission Control Protocol (TCP) over Internet Protocol (IP): TCP divides large data into smaller packets, assigns sequence number to the packet, transmits the data through IP layer, received the packets at the remote host, receives acknowledgement from the remote host, allows reassembling of data packets at the remote host. TCP is an error free protocol for transmission of data. It is a bit slow compared to User Datagram Protocol. TCP requires a dedicated connection.
Network protocols

- **UDP/IP**: User Datagram Protocol (UDP) over Internet Protocol (IP) divides data packets into smaller packets. UDP packets, called datagram packets, are transmitted over the IP network. UDP applies checksums to verify integrity of data packets. But, it does not care to verify whether all data packets were received by the remote host. UDP is fast but unreliable. UDP is adopted by streaming audio and streaming video channels on the Internet. UDP is not suitable for financial accounting applications like core banking (where reliability is required).

- **Telnet**: Telnet is a protocol working on TCP/IP to login and control a remote computer over the Internet. Telnet works on port number 23. It permits logging in to a computer through the Internet.
Network protocols

- **File Transfer Protocol (FTP):** File Transfer Protocol (FTP) helps in the transfer of large files between local and remote hosts over the Internet. Port number 21 is used for FTP control sequences and port number 20 is used for data transfer.

- **Simple Mail Transfer Protocol (FTP):** Simple Mail Transfer Protocol (FTP) is used for transfer of email between local host and remote host. Port number 25 is used SMTP. The Interim Mail Access Protocol (IMAP) uses port number 143, Post Office Protocol version 2 (POP2) uses port 109 and POP3 uses port number 110. Email transmission over Secure Socket Layer (SSL) uses port number 993.
Logical and physical addresses

- Logical address is the IP address assigned to a host when it is connected to a network.
- Physical address is the address of the networking hardware (like ethernet adapter).
- The mapping of a logical address to a physical address is called address binding.
Dynamic Host Configuration Protocol (DHCP)

- When a Local Area Network (LAN) is implemented, each new host connected to a LAN requires a unique IP address.
- Instead of assigning a static IP address to each host, the DHCP assigns a new IP for each connected host.
- DHCP claims back unused IP addresses and reuses the address, thus leading to efficient use of the addressing system.
- DHCP maintains a free pool of assignable IP addresses for new hosts connected to the network.
Internet

▶ The global network of networks is called Internet.
▶ Internet supports several modes of data exchange, like Hyper Text Transfer Protocol (HTTP), Hyper Text Transfer Protocol over Secure Socket Layer (HTTPS), File Transfer Protocol (FTP), Simple Mail Transfer Protocol (SMTP), Voice Over Internet Protocol (VOIP), etc.
▶ Internet supports many communication protocols like TCP/IP and UDP/IP.
▶ Internet originated through a United States Government project called ARPANET (Advanced Research Projects Agency Network) created in 1969.
▶ All nodes connected to the Internet share the Internet Protocol (IP).
▶ Internet works on the principle of Packet Switching, which means information packets are transmitted and received through various hardware and software components of the Internet till they reach the destination.
▶ Each Packet has a TTL (Time To Live), which is the duration
Introduction to WWW

- The WWW (World Wide Web) is governed by W3C (World Wide Web Consortium).
- WWW works through Hyper Text Transfer Protocol (HTTP) and Hyper Text Transfer Protocol over Secure Socket Layer (HTTPS) on top of the TCP/IP protocol stack.
- Web pages are created using Hyper Text Markup Language (HTML).
- WWW was invented by Tim Berners Lee at the CERN labs, Geneva.
- Hyper text helps to create navigational links called hyper links.
- Each web address is called a URL (Uniform Resource Locator).
- Each website has a web server which shares its data with clients.
- Web clients are called browsers.
- First web browser was called WorldWideWeb and was created by Tim Berners Lee.
Web browser

- Web browser receives data from a web server and renders the same on the screen of the client machine.
- First web browser was called WorldWideWeb and was created by Tim Berners Lee.
- Most popular web browsers are Firefox, Google Chrome, Opera, Microsoft Edge, Apple Safari, etc.
- Browsers like Netscape Navigator, Internet Explorer are dead for all practical purposes.
- Web browser essentially renders the text, images, video and animations from a web page.
- The address bar of the web browser can be opened using the shortcut Ctrl+L.
- Normally, pressing Ctrl+S saves the web page, Ctrl+P prints the web page, Ctrl+T opens new tab, Ctrl+Page Up/ Ctrl+Page Down navigate through tabs.
Internet server and search engine

- Internet server is a software that sends pages requested through URL.
- The data sent by the web server is rendered by the web browser.
- Web server usually runs on port number 80 (HTTP) and port number 443 (HTTPS).
- Apache web server is the most popular open source web server.
- Microsoft IIS (Internet Information Server), nginx, GWS (Google Web Server), etc. are some of the most common, commercially supported web servers.
- At hardware level, a computer hardware that helps the running of web server software is also called a web server.
- Rack mounted servers with option for inserting or removing server machines is most common in the server industry.
Domain Name System (DNS)

▶ Domain Name System (DNS) is the convention used for naming URL.
▶ Different components of URL are separated by dot (.).
▶ The URL labels identify the owner of the domain (e.g., google, yahoo, rediff, microsoft, etc.), the type of organization (e.g., .com for commercial ventures, .edu for educational Institutions, .org for organizations, .in for Indian domains, etc.)
▶ Domain names are mapped to an IPV4 or IPV6 address.
▶ Address Resolution Protocol (ARP) is used by servers which take human readable address and send back IP address.
▶ Reverse Address Resolution Protocol (RARP) is used by servers which take IP address and send the human readable address in return.
▶ DNS helps the conversion between names and IP addresses.
Email

- The system for electronic transmission of text and documents over a network from the sender to recipient is called email.
- Email clients have made it possible to access mailing system from the browser or dedicated client programs.
- Email messages are fast in message delivery.
- the most popular email servers are gmail.com, yahoo.com, rediff.com, rediffmail.com, ymail.com, icloud.com, hotmail.com, etc.
- Corporate companies have their own email servers with their own domains.
- To use email service, a person needs to register and obtain an email address from any of the email servers.
- To login, the URL of the email server should be accessed. Login credentials are the email address and password of the
Video chat tool

- Video chat tools help in sharing of live video between the caller and the receiver.
- Video chat tools like Viber, Skype, Facebook Messenger, Google Hangouts, Instagram, etc. are widely used.
- Video calling facility works through data streaming over the Internet.
Voice Over IP (VOIP)

- Voice Over Internet Protocol (VOIP) is a system for making audio calls over the Internet.
- VOIP clients bind to the mobile number of the user.
- When VOIP call is made, the recipient cannot distinguish the call from a GSM (Global System for Mobile communication) call.
- VOIP streams audio over the Internet and uses the mobile number of the caller as the identifier.
Social media networking

▶ Social media permits sharing of casual, usually non-commercial information with one or several other persons.
▶ Social media permits sharing of photos, videos, text messages, etc. over the Internet.
▶ Social media websites like Facebook, Twitter, LinkedIn Instagram, Skype, Hangouts, WhatsApp, Telegram, etc. are some of the most popular social media platforms.
▶ Social media encourages sharing of personal information and getting appreciation from the recipients.
▶ Social media has become one of the necessary evils of the modern society.
▶ Many modern day crimes relate to extracting information from innocent youngsters and women and using the same information for blackmailing the individual.
▶ Bullies in social media use fake identities and fake personal details to attract innocent persons.
▶ Each person using the social media should exercise self-restraint and should not share any information which can be
Cloud storage

- Cloud storage means the transmission and safe maintenance of data in remote data warehouse computers over the network.
- Since the files are stored in a specific location, the user can log in from any computer or mobile device and access the files.
- Since the data is accessible from any location, cloud storage removes the dependence on any single machine to maintain the data.
Web security

1. If we consider website as our home, the hacker or malware is a thief waiting to squander the wealth of the home.

2. Websites dealing with online transactions store sensitive information like credit/debit card number, name of owner, month & year of expiry and the CVV (Card Verification Value).

3. Websites run by hospitals store confidential data on the diagnosis and treatment offered to patients.

4. Websites of airline agencies and train booking services like irctc store travel and payment information related to innumerable customers.
5 Websites of search engines (like google in which people login for mail and do some search without logging out) save several search strings issued by the user and the types of result he or she was interested in.

6 The sensitive data held in the server are like the treasures which a hacker wishes to squander.

7 Some of the hackers simply leave a message (called defacing a website), some attackers delete vital data, some hackers use the available information to make as much money as possible from the website data.

8 Some attackers simply fire countless client requests from various IP addresses until the server system crashes due to overload.

9 Although all attacks of website vulnerability may not result in monetary loss, defacement is a fearful possibility, especially for a Government website held in high esteem by the Citizens.
Common vulnerabilities in websites

1 **SQL Injection**: The hacker issues a series of innocent SQL looking SQL queries, which lead to a step by step compromise of the database server, resulting in the revelation id and password of the website administrator.

2 **Cross Site Scripting (XSS)**: Some client side script (in Javascript or VBScript) is embedded in an otherwise normal looking website. The client side script captures vital details from the user and transmit the same to a hacker.

3 **Broken authentication and session management**: A user logging in to a web site offering email, social media or banking services may lose his session to a hacker if any security details captured through vulnerabilities in code. Then the hacker assumes the role of the client and can use exploit the session to gain money or information.
4 **Insecure direct object reference**: The URL of a website should only access items contained inside the root directory of the web server. If any object (file, directory, database, etc.) outside the root directory are directly referenced in the URL, a hacker can easily gain access to the internals of a computer.

5 **Security misconfiguration**: The web server, the database server, the FTP server and email server are to be separately configured for security. If any weakness in configuration is found, a hacker will gain control over the server framework.

6 **Cross Site Request Forgery**: During a client session on email, bank or social media, a hacker may send request to control the browser of innocent client. Then the hacker gains access to the server using the credentials of the user.
Malicious Software (Malware) types

▶ A piece of software intended to cause damage to a computer host is called malware.

▶ Malware can be transmitted through storage media (like pen drive), malicious websites, email attachment (BOT), etc.
Malware can be classified into:

(i) **Adware**: Malware intended to throw unwanted advertisement on the host computer is called adware.

(ii) **Bot**: Malware intended to imitate a human client and perform malicious operations (like Denial of Service (DoS) attack) is called bot.

(iii) **Ransomware**: Malware which locks user data and demands payment of money (ransome) to a specific account for unlocking the data is called ransomware.

(iv) **Rootkit**: Malware intended to grant all permissions to a remote user to control local computer is called rootkit. It makes way for some remote user to access and delete information from local computer.

(v) **Spyware**: Malware intended to collect data relating to user activities, accounts and passwords and send them to some malicious host is called spyware. It works without the knowledge of the local user.

(vi) **Trojan Horse**: Malware which dupes as a good program but starts damaging the computer after entering local host is called trojan horse.

(vii) **Virus**: Malware which copies itself to the executable files, documents, folders, etc., spreads to other computers is a virus.
Concepts of Static and Dynamic Web pages. Introduction to HTML and various tags in HTML. Creating Forms with controls using HTML. Concepts of CSS and applying CSS to HTML. Introduction to open source CMS viz., Joomla, Wordpress, etc. and web authoring tools viz. Kompozer, FrontPage etc.
Static web pages

- Web pages which provide fixed content in the form of text, images and video without any user interaction are called static web pages.
- Web pages which interact with the user and provide based on the actions of the user are called dynamic web pages.
- Static web pages use HTML (Hyper Text Markup Language).
Dynamic web pages

- Dynamic web page is created by scripts which result in dynamic content based on the interaction of the user.
- Dynamic web pages can be created by:
  (i) **Server side script**: Script stored in the server and written in languages like PHP, Perl, Python, ASP.NET, etc. is called server side script. Server side scripts are useful for data storage, data retrieval, storing photos received from forms, authentication of login, managing session, etc.
  (ii) **Client side script**: Script written in languages like JavaScript, VBScript, etc. and running inside a browser (or the client) is called client side script. Client side scripts are suitable for error checking in forms and dynamic interaction using mouse or keyboard.
- A combination of client side and server side scripting will render a web page highly attractive and useful.
HTML tags

All HTML tags have a corresponding closing tag. Some tags might not have a closing tag with end with / > symbol.

- **HTML**: All HTML files begin with `<HTML>` and end with `< /HTML>`.
- **HEAD**: The title and meta information of a HTML file are entered inside a pair of `<HEAD>` and `< /HTML>` tags.
- **TITLE**: Title of the document is enclosed inside a pair of `<TITLE>` and `< /TITLE>` tags.
- **BODY**: All contents of the HTML file are enclosed inside a `<BODY>` and `< /BODY>`.
- **H1 to H6**: Defines various levels of headings from level 1 to level 6.
- **TABLE**: Table tag encloses a table. It has border option wherein border thickness can be specified. TH tag defines table header, TD defines table column and TR defines table row.
- **P**: defines a paragraph.
HTML tags

- **INPUT**: Input tag can have several type options (like text, date, email, number, etc.), a name, an ID and other attributes like readonly if necessary.

- **SELECT**: Select tag displays a combo box with various options enclosed inside OPTION tags. Each option would have a value property.

- **OL**: Ordered list. Each list item is defined by LI tag.

- **UL**: Un-ordered list. Each list item is defined by LI tag.

- **FORM**: The contents enclosed inside a FORM tag can be submitted to a server side script for data storage and be accessed by a client side script for validation of input. It has options for ACTION, METHOD (POST or GET), etc.

- **SUBMIT**: Submit button completes form data entry and sends the data to specified URL.

- **RESET**: Reset button clears all entries from a form and provides a blank form.
HTML tags

- **BUTTON**: Displays a button with specified name, text and ID.

- **A**: Anchor tag for hyper text linking. HREF option takes the URL to be loaded when the link is clicked.

- **B**: BOLD tag.

- **FONT**: specifies name, color and size for font.

- **IMG**: IMS tag loads an image specified by the SRC option.

- **CENTER**: Centre aligns text and objects.

- **SPAN**: A place holder with an ID and name.

- **MARQUEE**: Marquee tag displays scrolling message, as seen at the bottom of television display.
## Special characters in HTML

### Table: Special characters in HTML

<table>
<thead>
<tr>
<th>code</th>
<th>char</th>
<th>code</th>
<th>char</th>
<th>code</th>
<th>char</th>
<th>code</th>
<th>char</th>
</tr>
</thead>
<tbody>
<tr>
<td>&quot;</td>
<td>&quot;</td>
<td>#</td>
<td>#</td>
<td>$</td>
<td>$</td>
<td>%</td>
<td>%</td>
</tr>
<tr>
<td>&amp;</td>
<td>&amp;</td>
<td>'</td>
<td>’</td>
<td>(</td>
<td>(</td>
<td>)</td>
<td>)</td>
</tr>
<tr>
<td>*</td>
<td>*</td>
<td>+</td>
<td>+</td>
<td>,</td>
<td>,</td>
<td>−</td>
<td>-</td>
</tr>
<tr>
<td>.</td>
<td>.</td>
<td>/</td>
<td>/</td>
<td>:</td>
<td>:</td>
<td>;</td>
<td>;</td>
</tr>
<tr>
<td>&lt;</td>
<td>&lt;</td>
<td>=</td>
<td>=</td>
<td>&gt;</td>
<td>&gt;</td>
<td>?</td>
<td>?</td>
</tr>
<tr>
<td>@</td>
<td>@</td>
<td>[</td>
<td>[</td>
<td>\</td>
<td>\</td>
<td>]</td>
<td>]</td>
</tr>
<tr>
<td>^</td>
<td>^</td>
<td>_</td>
<td>_</td>
<td>`</td>
<td>‘</td>
<td>{</td>
<td>{</td>
</tr>
<tr>
<td>}</td>
<td>}</td>
<td>|</td>
<td>—</td>
<td>˜</td>
<td>~</td>
<td>α</td>
<td>α</td>
</tr>
<tr>
<td>β</td>
<td>β</td>
<td>γ</td>
<td>γ</td>
<td>δ</td>
<td>δ</td>
<td>π</td>
<td>π</td>
</tr>
<tr>
<td>θ</td>
<td>θ</td>
<td>φ</td>
<td>φ</td>
<td>ψ</td>
<td>ψ</td>
<td>ω</td>
<td>ω</td>
</tr>
</tbody>
</table>
Creating HTML pages

- HTML pages can be edited using text editor (notepad, gedit, etc.) or can be edited using specialized tools like Dreamweaver, Komposer, etc.

- The HTML files should be previewed in a browser (like Firefox, Google Chrome, Edge, Safari, Opera, etc.).

- Firefox browser provides a debugging tool to spot errors through Developer Console (shortcut: Ctrl+Shift+K).

- Some of the special characters used in HTML are tabulated in Table 7.

- Sample HTML pages and their results are presented in the following subsections.
Static information page

Welcome to my introduction page: Your name

My name is .... I am studying COPA trade in Govt. ITI for Women, Puducherry. I am preparing for first semester examination. The examination starts on 29-Jan-2018.

The second semester starts on 01-02-2018.
Welcome to my introduction page: Your name

My name is .... I am studying COPA trade in Govt. ITI for Women, Puducherry. I am preparing for first semester examination. The examination starts on 29-Jan-2018.

The second semester starts on 01-02-2018.
Creating ordered and unordered lists

```html
<html>
<head>
<title>List of computer peripherals</title>
<style>
h1{text-align:center; color:blue}
ol {font-size:120%; color:red}
</style>
</head>
<body>
<h1>List of computer peripherals</h1>
<ol>
<li>Monitor</li>
<li>Keyboard</li>
<li>Mouse</li>
<li>Printer</li>
<li>Line matrix printer</li>
<li>Daisy wheel printer</li>
<li>Golf ball printer</li>
<li>Dot matrix printer</li>
<li>Inkjet printer</li>
<li>LASER printer</li>
<li>Thermal printer</li>
<li>Dot matrix printer</li>
<li>Scanner</li>
</ol>
</body>
</html>
```
List of computer peripherals

1. Monitor
2. Keyboard
3. Mouse
4. Printer
   - Line matrix printer
   - Daisy wheel printer
   - Golf ball printer
   - Dot matrix printer
   - Inkjet printer
   - LASER printer
   - Thermal printer
   - Dot matrix printer
5. Scanner

Figure: List page in HTML
Creating table

```html
<html>
<head>
    <title>Ice creams</title>
    <style>
        h1 { color:green; text-align:center; }
        th { vertical-align:middle; text-align:centre; font-weight:bold; background:lightgreen; color:red; font-size:120%; }
        #odd { vertical-align:middle; text-align:centre; font-weight:normal; background:#FFBBBB; color:blue; font-size:120%; }
        #even { vertical-align:middle; text-align:centre; font-weight:normal; background:#BBBBFF; color:red; font-size:120%; }
    </style>
</head>
<body>
<h1>Types of ice cream (<your name>)</h1>
<table border=1>
<tr><th>Sl. No.</th><th>Name</th><th>Cream</th><th>Rate</th></tr>
<tr id="odd"><td>1</td><td>Dessert</td><td><img width=20% src="ice-creams/01-dessert.jpg"></td><td>Rs.120/-</td></tr>
<tr id="even"><td>2</td><td>Cone</td><td><img width=20% src="ice-creams/02-cone.jpg"></td><td>Rs.60/-</td></tr>
<tr id="odd"><td>3</td><td>Chocolate</td><td><img width=20% src="ice-creams/03-chaco.jpg"></td><td>Rs.90/-</td></tr>
<tr id="even"><td>4</td><td>Cone</td><td><img width=20% src="ice-creams/04-strawberry.jpg"></td><td>Rs.100/-</td></tr>
</table>
</body>
</html>
```
### Types of ice cream ()

<table>
<thead>
<tr>
<th>Sl. No</th>
<th>Name</th>
<th>Cream</th>
<th>Rate</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Dessert</td>
<td></td>
<td>Rs.120/-</td>
</tr>
<tr>
<td>2</td>
<td>Cone</td>
<td></td>
<td>Rs.60/-</td>
</tr>
<tr>
<td>1</td>
<td>Chocolate</td>
<td></td>
<td>Rs.90/-</td>
</tr>
<tr>
<td>4</td>
<td>Cone</td>
<td></td>
<td>Rs.100/-</td>
</tr>
</tbody>
</table>
Cascading Style Sheet (CSS)

- A text file containing style properties is called Cascading Style Sheet (CSS).
- CSS defines how
- The cascading sheet can be linked to a HTML file at the header section.
- The following tag helps to insert a CSS sheet:
  `<link rel=”stylesheet” type=”text/css” href=”<style-sheet>.css”>`
- The following subsection shows the appearance of HTML file with different CSS linkages.
- Styles may be specified in any one of the following methods:
  (a) **Inline style**: Specifying style just inside the tag is called inline style specification. e.g., `<h1 style=”color:#FF0000;text-align:center;background-color:#0000FF”>Heading</h1>` specifies that text should be red in color, alignment should be centred and background should be blue.
Red color theme with style sheet

<html>
<head>
<title>Red style</title>
<link rel="stylesheet" type="text/css" href="red.css" />
</head>
<body>
<h1>Ridge TV Channel</h1>
<marquee;breakinb news &nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbs
Red color theme with style sheet

body {
    background-color: #222277;
    font-size: 300%;
    color: #FF0000
}

h1 {
    color: #FF0000;
    text-align: center
}

marquee {
    background-color: #0000FF
}
Green color theme with style sheet

<html>
<head>
<title>Green style</title>
<link rel="stylesheet" type="text/css" href="green.css" />
</head>
<body>
<h1>Ridge TV Channel</h1>
<marquee>
Breaking news
Nothing new under the Sun!
Keep your cool!!
</marquee>
</body>
</html>
Green color theme with style sheet

The green.css file is shown below:

```css
body {
  background-color: #222266;
  font-size: 300%;
  color: #00FF00
}

h1 {
  color: #00FF00;
  text-align: center
}

marquee {
  background-color: #0000FF
}
```
CSS Property elements

1. **align-content**: Align content to left, right or center.
2. **background**: Specifies background color (Color is specified in #000000 (black) #FFFFFF (white). First 2 digits represent red, second 2 digits represent green and third 2 digits represent blue. Each digit can change from 0 to F under hexadecimal system).
3. **background-color**: Specifies background color (Color is specified in #000000 (black) #FFFFFF (white). First 2 digits represent red, second 2 digits represent green and third 2 digits represent blue. Each digit can change from 0 to F under hexadecimal system).
4. **border**: size, type (solid, dotted, dashed, double dashed) and color of border.
5. **color**: Color of element.
6. **font-style**: Font style may be italic, normal, oblique.
7. **font-weight**: may be normal, bold, bolder, lighter (number 400 is normal, 700 is bold).
8. **font-size**: Font size may be specified in pixels (e.g., 24px) or...
Creating HTML forms

▶ Forms begin with the `<form>` tag and end with `</form>` tag.
▶ Action property of form refers to the URL to be invoked when the form is submitted.
▶ Method property of form submission may be GET or POST.
▶ Input type of ”submit” may be used to submit data to the specified action URL.
▶ Input type of ”reset” may be used for clearing all changes to the form.
▶ Some simple forms to calculate sum, difference, product, quotient, age and power are presented in the following sections.
HTML form for greeting

HTML form to greet a person is presented in the following HTML code:

```html
<html>
<head>
<title>Enter your name</title>
<link rel="stylesheet" type="text/css" href="red.css"/>
</head>
<body>
<h1>Name form</h1>
<form name="nameForm" action="#" method="POST">
<center>
<table border=0>
<tr><td>Name</td><td>:</td><td><input type="text" name="n" placeholder="Name"></td></tr>
</table>
<input type="submit" value="Greeting" onClick="alert('Welcome '+n.value)"/>
</center>
</form>
</body>
</html>
```
HTML form for addition

HTML form to add 2 numbers:
<html>
<head>
<title>Add numbers</title>
<link rel="stylesheet" type="text/css" href="red.css"/>
</head>
<body>
<h1>Add form</h1>
<form name="addForm" action="#" method="POST">
<center>
<table border=0>
<tr><td>Enter x</td><td>:</td><td><input type="text" name="x" /></td></tr>
<tr><td>Enter y</td><td>:</td><td><input type="text" name="y" /></td></tr>
<tr><td colspan=3 style="text-align:center"><input type="button" value="Add" onClick="z.value = Number(x.value) + Number(y.value)" /></td></tr>
<tr><td>Result</td><td>:</td><td><input type="text" name="z" readonly /></td></tr>
</table>
</center>
</form>
</body>
</html>
**HTML form for subtraction**

**HTML form to subtract a number from another numbers:**

```html
<html>
<head>
<title>Subtract numbers</title>
<link rel="stylesheet" type="text/css" href="red.css"/>
</head>
<body>
<h1>Subtract form</h1>
<form name="subForm" action="#" method="POST">
<center>
<table border=0>
<tr><td>Enter x</td>: <td><input type="text" name="x"></td></tr>
<tr><td>Enter y</td>: <td><input type="text" name="y"></td></tr>
<tr><td colspan=3 style="text-align:center"> <input type="button" value="Subtract" onClick="z.value = Number(x.value) - Number(y.value)" /></td></tr>
<tr><td>Result</td>: <td><input type="text" name="z" readonly></td></tr>
</table>
</center>
</form>
</body>
</html>
```
HTML form for multiplication

HTML form to multiply 2 numbers:

```html
<html>
<head>
<title>Multiplication form</title>
<link rel="stylesheet" type="text/css" href="red.css"/>
</head>
<body>
<h1>Multiply form</h1>
<form name="mulForm" action="#" method="POST">
<center>
<table border=0>
<tr><td>Enter x</td>:<td><input type="text" name="x"></td></tr>
<tr><td>Enter y</td>:<td><input type="text" name="y"></td></tr>
<tr><td colspan=3 style="text-align:center"><input type="button" value="Multiply" onClick="z.value = Number(x.value) * Number(y.value)"></td></tr>
<tr><td>Result</td>:<td><input type="text" name="z" readonly></td></tr>
</table>
</center>
</form>
</body>
</html>
```
HTML form for division

HTML form to divide a number by another numbers:

```html
<html>
<head>
<title>Division of numbers</title>
<link rel="stylesheet" type="text/css" href="red.css">
</head>
<body>
<h1>Division form</h1>
<form name="divForm" action="#" method="POST">
<center>
<table border=0>
<tr><td><input type="text" name="x"></td></tr>
<tr><td><input type="text" name="y"></td></tr>
<tr><td colspan=3 style="text-align:center"><input type="button" value="Divide" onClick="z.value = Number(x.value) / Number(y.value)"></td></tr>
<tr><td><input type="text" name="z" readonly></td></tr>
</table></center>
</form>
</body>
</html>
```
HTML form to calculate age

HTML form to calculate age:

```html
<html>
<head>
<title>Age calculation</title>
<link rel="stylesheet" type="text/css" href="green.css" />
</head>
<body>
<h1>Age calculation</h1>
<form name="ageForm" action="#" method="POST">
<center>
<table border=0>
<tr><td><br>Enter DOB</td><td>:</td><td><input type="date" name="dob"></td></tr>
<tr><td colspan=3 style="text-align:center"><input type="button" value="Age" onClick="res.value = (new Date(Date.now() - new Date(dob.value).getTime()).getUTCFullYear()-1970)"></td></tr>
<tr><td><br>Age</td><td>:</td><td><input type="text" name="res" readonly></td></tr>
</table>
</center>
</form>
</body>
</html>
```
HTML form to calculate power of a number

HTML form to calculate power of a number:

```html
<html>
<head>
<title>Power</title>
<link rel="stylesheet" type="text/css" href="green.css" />
</head>
<body>
<h1>Power form</h1>
<form name="powForm" action="pow.php" method="POST">
<center>
<table border=0>
<tr><td><center>
Enter x</center></td>:<td><input type="text" name="x" /></td></tr>
<tr><td><center>Enter y</center></td>:<td><input type="text" name="y" /></td></tr>
<tr><td colspan=3 style="text-align:center"><input type="submit" value="Power" /> <input type="reset" value="Reset" /></td></tr>
</table>
</center>
</form>
</body>
</html>
```
PHP script to calculate power of a number:

```php
<?php
$x = $_POST['x'];
y = $_POST['y'];
z = pow($x, $y);
echo $x . " ^ " . $y . " = " . $z;
?>
```